summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/tea/files')
-rw-r--r--app-editors/tea/files/tea-62.1.1-fix-desktop.patch26
-rw-r--r--app-editors/tea/files/tea-62.1.1-qt-option.patch41
2 files changed, 67 insertions, 0 deletions
diff --git a/app-editors/tea/files/tea-62.1.1-fix-desktop.patch b/app-editors/tea/files/tea-62.1.1-fix-desktop.patch
new file mode 100644
index 000000000000..36af0b5c0027
--- /dev/null
+++ b/app-editors/tea/files/tea-62.1.1-fix-desktop.patch
@@ -0,0 +1,26 @@
+From 8fb78950cd2e50c76cbf34b5245a413a5f3477f0 Mon Sep 17 00:00:00 2001
+From: Alfred Wingate <parona@protonmail.com>
+Date: Sun, 19 Nov 2023 12:56:05 +0200
+Subject: [PATCH] Remove whitespace at the end the desktop file
+
+ * QA Notice: This package installs one or more .desktop files that do not
+ * pass validation.
+ *
+ * /usr/share/applications/tea.desktop: error: (will be fatal in the future): value "text/plain;application/epub+zip;application/fb2;application/vnd.openxmlformats-officedocument.wordprocessingml.document;application/vnd.oasis.opendocument.text;application/rtf;application/x-tex; " for key "MimeType" in group "Desktop Entry" contains value " " which is an invalid MIME type: " " does not contain a subtype
+ *
+
+Signed-off-by: Alfred Wingate <parona@protonmail.com>
+--- a/desktop/tea.desktop
++++ b/desktop/tea.desktop
+@@ -6,7 +6,7 @@ Icon=tea
+ Exec=tea %F
+ Categories=Utility;TextEditor;
+ StartupNotify=false
+-MimeType=text/plain;application/epub+zip;application/fb2;application/vnd.openxmlformats-officedocument.wordprocessingml.document;application/vnd.oasis.opendocument.text;application/rtf;application/x-tex;
++MimeType=text/plain;application/epub+zip;application/fb2;application/vnd.openxmlformats-officedocument.wordprocessingml.document;application/vnd.oasis.opendocument.text;application/rtf;application/x-tex;
+ NoDisplay=false
+ Version=1.1
+ Keywords=text editor;text;editor;
+--
+2.42.1
+
diff --git a/app-editors/tea/files/tea-62.1.1-qt-option.patch b/app-editors/tea/files/tea-62.1.1-qt-option.patch
new file mode 100644
index 000000000000..e4f2a580c6e9
--- /dev/null
+++ b/app-editors/tea/files/tea-62.1.1-qt-option.patch
@@ -0,0 +1,41 @@
+From 2ca1a29e67c9cee591dbab5a323764e435d46b2c Mon Sep 17 00:00:00 2001
+From: Alfred Wingate <parona@protonmail.com>
+Date: Sun, 19 Nov 2023 12:53:11 +0200
+Subject: [PATCH] Make qt6 a cmake option instead of letting automagic
+ handle it
+
+* qt_standard_project_setup() is >=qt-6.3 only, so put it under
+ Qt6_Found.
+
+Signed-off-by: Alfred Wingate <parona@protonmail.com>
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -11,8 +11,11 @@ set(CMAKE_AUTORCC ON)
+ enable_language(CXX)
+ enable_language(C)
+
+-find_package(Qt6 COMPONENTS Core Widgets)
+-if (NOT Qt6_FOUND)
++option(USE_QT6 "Build against QT6" ON)
++
++if (USE_QT6)
++ find_package(Qt6 REQUIRED COMPONENTS Core Widgets)
++else()
+ find_package(Qt5 5.15 REQUIRED COMPONENTS Core Widgets)
+ endif()
+
+@@ -22,10 +25,8 @@ message("+ Qt6 found")
+ set(CMAKE_CXX_STANDARD 17)
+ set(CMAKE_CXX_STANDARD_REQUIRED ON)
+ find_package(Qt6 COMPONENTS Core5Compat REQUIRED)
+-endif()
+-
+-
+ qt_standard_project_setup()
++endif()
+
+
+ set(PROJECT "tea-qt")
+--
+2.42.1
+