summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/tea')
-rw-r--r--app-editors/tea/Manifest1
-rw-r--r--app-editors/tea/metadata.xml1
-rw-r--r--app-editors/tea/tea-44.1.1.ebuild65
3 files changed, 67 insertions, 0 deletions
diff --git a/app-editors/tea/Manifest b/app-editors/tea/Manifest
index 213372c58925..82d6b052d7c9 100644
--- a/app-editors/tea/Manifest
+++ b/app-editors/tea/Manifest
@@ -1 +1,2 @@
DIST tea-44.1.0.tar.bz2 402335 BLAKE2B 3c3191d6fdcd0e0c73ba408e3219a65d28d2950ebba905a003555fb1ceebeb6ce8dc6448762267e981e429fb0513d21d49b8b25fc7881daaded5f04034cf1ff6 SHA512 a430ed6d23d828b12235f61ad3d37f36c28754dcde8ac6d382a251f4b21cc253d70adab96814ee2d31fd6e92d4b5fbc941386b6d485716020800b5fa5e71b194
+DIST tea-44.1.1.tar.bz2 425326 BLAKE2B e674456c428bbecd5afb256280bccb61b6385492153955625c158dcfebba0ed31caebdcc06bc1f809517badddef3d97245a4bc873bcc0593957647becdebf62b SHA512 fc7bf6f76ac3a48767a39ff5bcada4c7dae40950bfd9aca4021b3581e1b702c73f2608b070306dd528932d5eaa73bf01632a4376bbb71deaf1189a0f790c05a9
diff --git a/app-editors/tea/metadata.xml b/app-editors/tea/metadata.xml
index 86348fa600a3..a3b87502efe6 100644
--- a/app-editors/tea/metadata.xml
+++ b/app-editors/tea/metadata.xml
@@ -13,5 +13,6 @@
<use>
<flag name="aspell">Enable spellchecking using <pkg>app-text/aspell</pkg></flag>
<flag name="hunspell">Enable spellchecking using <pkg>app-text/hunspell</pkg></flag>
+ <flag name="qml">Enable support for plugins using QML</flag>
</use>
</pkgmetadata>
diff --git a/app-editors/tea/tea-44.1.1.ebuild b/app-editors/tea/tea-44.1.1.ebuild
new file mode 100644
index 000000000000..f11b523d5d22
--- /dev/null
+++ b/app-editors/tea/tea-44.1.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils qmake-utils xdg-utils
+
+DESCRIPTION="Small, lightweight Qt text editor"
+HOMEPAGE="https://tea.ourproject.org/"
+SRC_URI="https://tea.ourproject.org/dloads/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="aspell djvu hunspell pdf +qml"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ sys-libs/zlib
+ aspell? ( app-text/aspell )
+ djvu? ( app-text/djvu )
+ hunspell? ( app-text/hunspell:= )
+ pdf? ( app-text/poppler[qt5] )
+ qml? ( dev-qt/qtdeclarative:5 )
+"
+DEPEND="${RDEPEND}
+ hunspell? ( virtual/pkgconfig )
+"
+
+DOCS=( AUTHORS ChangeLog NEWS NEWS-RU TODO )
+
+src_configure() {
+ eqmake5 src.pro \
+ PREFIX="/usr" \
+ $(use aspell || echo CONFIG+=noaspell) \
+ $(use djvu && echo CONFIG+=usedjvu) \
+ $(use hunspell || echo CONFIG+=nohunspell) \
+ $(use pdf && echo CONFIG+=usepoppler) \
+ $(use qml || echo CONFIG+=noqml)
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+
+ docinto html
+ dodoc manuals/*.html
+
+ insinto /usr/share/qt5/translations
+ doins translations/${PN}_*.qm
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}