summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/vim/vim-9999.ebuild')
-rw-r--r--app-editors/vim/vim-9999.ebuild181
1 files changed, 120 insertions, 61 deletions
diff --git a/app-editors/vim/vim-9999.ebuild b/app-editors/vim/vim-9999.ebuild
index 5bc04c0d2b05..850c5dab10c6 100644
--- a/app-editors/vim/vim-9999.ebuild
+++ b/app-editors/vim/vim-9999.ebuild
@@ -1,30 +1,37 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-VIM_VERSION="8.2"
-PYTHON_COMPAT=( python3_{6,7,8} )
+EAPI=8
+
+# Please bump with app-editors/vim-core and app-editors/gvim
+
+VIM_VERSION="9.0"
+VIM_PATCHES_VERSION="9.0.1000"
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+PYTHON_COMPAT=( python3_{10..11} )
PYTHON_REQ_USE="threads(+)"
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+USE_RUBY="ruby27 ruby30 ruby31"
-inherit vim-doc flag-o-matic bash-completion-r1 python-single-r1 ruby-single desktop xdg-utils
+inherit vim-doc flag-o-matic bash-completion-r1 lua-single python-single-r1 ruby-single toolchain-funcs desktop xdg-utils
if [[ ${PV} == 9999* ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/vim/vim.git"
else
SRC_URI="https://github.com/vim/vim/archive/v${PV}.tar.gz -> ${P}.tar.gz
- https://dev.gentoo.org/~zlogene/distfiles/app-editors/vim/vim-8.2.0360-gentoo-patches.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ https://gitweb.gentoo.org/proj/vim-patches.git/snapshot/vim-patches-vim-${VIM_PATCHES_VERSION}-patches.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
fi
DESCRIPTION="Vim, an improved vi-style text editor"
-HOMEPAGE="https://vim.sourceforge.io/ https://github.com/vim/vim"
+HOMEPAGE="https://www.vim.org https://github.com/vim/vim"
-SLOT="0"
LICENSE="vim"
-IUSE="X acl cscope debug gpm lua luajit minimal nls perl python racket ruby selinux sound tcl terminal vim-pager"
+SLOT="0"
+IUSE="X acl crypt cscope debug gpm lua minimal nls perl python racket ruby selinux sound tcl terminal vim-pager"
REQUIRED_USE="
+ lua? ( ${LUA_REQUIRED_USE} )
python? ( ${PYTHON_REQUIRED_USE} )
vim-pager? ( !minimal )
"
@@ -34,13 +41,13 @@ RDEPEND="
>=sys-libs/ncurses-5.2-r2:0=
nls? ( virtual/libintl )
acl? ( kernel_linux? ( sys-apps/acl ) )
+ crypt? ( dev-libs/libsodium:= )
cscope? ( dev-util/cscope )
gpm? ( >=sys-libs/gpm-1.19.3 )
- lua? (
- luajit? ( dev-lang/luajit:2= )
- !luajit? ( dev-lang/lua:0[deprecated] )
+ lua? ( ${LUA_DEPS}
+ $(lua_gen_impl_dep 'deprecated' lua5-1)
)
- !minimal? ( ~app-editors/vim-core-${PV} )
+ ~app-editors/vim-core-${PV}
vim-pager? ( app-editors/vim-core[-minimal] )
perl? ( dev-lang/perl:= )
python? ( ${PYTHON_DEPS} )
@@ -51,30 +58,43 @@ RDEPEND="
tcl? ( dev-lang/tcl:0= )
X? ( x11-libs/libXt )
"
-
-DEPEND="
- ${RDEPEND}
- sys-devel/autoconf
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+"
+# configure runs the Lua interpreter
+BDEPEND="
+ dev-build/autoconf
+ lua? ( ${LUA_DEPS} )
nls? ( sys-devel/gettext )
"
+PDEPEND="!minimal? ( app-vim/gentoo-syntax )"
+
+if [[ ${PV} != 9999* ]]; then
+ # Gentoo patches to fix runtime issues, cross-compile errors, etc
+ PATCHES=(
+ "${WORKDIR}/vim-patches-vim-${VIM_PATCHES_VERSION}-patches"
+ )
+fi
+
+# platform-specific checks (bug #898452):
+# - acl() -- Solaris
+# - statacl() -- AIX
+QA_CONFIG_IMPL_DECL_SKIP=(
+ 'acl'
+ 'statacl'
+)
pkg_setup() {
- # people with broken alphabets run into trouble. bug 82186.
+ # people with broken alphabets run into trouble. bug #82186.
unset LANG LC_ALL
export LC_COLLATE="C"
- # Gnome sandbox silliness. bug #114475.
- mkdir -p "${T}"/home || die "mkdir failed"
- export HOME="${T}"/home
-
+ use lua && lua-single_pkg_setup
use python && python-single-r1_pkg_setup
}
src_prepare() {
- if [[ ${PV} != 9999* ]] ; then
- # Gentoo patches to fix runtime issues, cross-compile errors, etc
- eapply "${WORKDIR}"/patches/
- fi
+ default
# Fixup a script to use awk instead of nawk
sed -i -e \
@@ -89,7 +109,7 @@ src_prepare() {
# Use exuberant ctags which installs as /usr/bin/exuberant-ctags.
# Hopefully this pattern won't break for a while at least.
- # This fixes bug 29398 (27 Sep 2003 agriffis)
+ # This fixes bug #29398 (27 Sep 2003 agriffis)
sed -i -e \
's/\<ctags\("\| [-*.]\)/exuberant-&/g' \
"${S}"/runtime/doc/syntax.txt \
@@ -98,19 +118,12 @@ src_prepare() {
"${S}"/runtime/menu.vim \
"${S}"/src/configure.ac || die 'sed failed'
- # Don't be fooled by /usr/include/libc.h. When found, vim thinks
- # this is NeXT, but it's actually just a file in dev-libs/9libs
- # This fixes bug 43885 (20 Mar 2004 agriffis)
- sed -i -e \
- 's/ libc\.h / /' \
- "${S}"/src/configure.ac || die 'sed failed'
-
# gcc on sparc32 has this, uhm, interesting problem with detecting EOF
# correctly. To avoid some really entertaining error messages about stuff
# which isn't even in the source file being invalid, we'll do some trickery
# to make the error never occur. bug 66162 (02 October 2004 ciaranm)
find "${S}" -name '*.c' | while read c; do
- echo >> "$c" || die "echo failed"
+ echo >> "$c" || die "echo failed"
done
# conditionally make the manpager.sh script
@@ -135,18 +148,24 @@ src_prepare() {
cp -v "${S}"/src/config.mk.dist "${S}"/src/auto/config.mk || die "cp failed"
- sed -i -e \
- "s:\\\$(PERLLIB)/ExtUtils/xsubpp:${EPREFIX}/usr/bin/xsubpp:" \
- "${S}"/src/Makefile || die 'sed for ExtUtils-ParseXS failed'
+ # Fix bug 18245: Prevent "make" from the following chain:
+ # (1) Notice configure.ac is newer than auto/configure
+ # (2) Rebuild auto/configure
+ # (3) Notice auto/configure is newer than auto/config.mk
+ # (4) Run ./configure (with wrong args) to remake auto/config.mk
+ sed -i 's# auto/config\.mk:#:#' src/Makefile || die "Makefile sed failed"
+ rm src/auto/configure || die "rm failed"
- eapply_user
+ # bug 908961
+ if use elibc_musl ; then
+ sed -i -e '/ja.sjis/d' src/po/Make_all.mak || die
+ fi
}
src_configure() {
- local myconf=()
- # Fix bug 37354: Disallow -funroll-all-loops on amd64
- # Bug 57859 suggests that we want to do this for all archs
+ # Fix bug #37354: Disallow -funroll-all-loops on amd64
+ # Bug #57859 suggests that we want to do this for all archs
filter-flags -funroll-all-loops
# Fix bug 76331: -O3 causes problems, use -O2 instead. We'll do this for
@@ -154,23 +173,17 @@ src_configure() {
# multiple archs...
replace-flags -O3 -O2
- # Fix bug 18245: Prevent "make" from the following chain:
- # (1) Notice configure.ac is newer than auto/configure
- # (2) Rebuild auto/configure
- # (3) Notice auto/configure is newer than auto/config.mk
- # (4) Run ./configure (with wrong args) to remake auto/config.mk
- sed -i 's# auto/config\.mk:#:#' src/Makefile || die "Makefile sed failed"
- rm src/auto/configure || die "rm failed"
emake -j1 -C src autoconf
- # This should fix a sandbox violation (see bug 24447). The hvc
- # things are for ppc64, see bug 86433.
+ # This should fix a sandbox violation (see bug #24447). The hvc
+ # things are for ppc64, see bug #86433.
for file in /dev/pty/s* /dev/console /dev/hvc/* /dev/hvc*; do
if [[ -e "${file}" ]]; then
- addwrite $file
+ addwrite ${file}
fi
done
+ local myconf=()
if use minimal; then
myconf=(
--with-features=tiny
@@ -196,15 +209,13 @@ src_configure() {
--with-features=huge
$(use_enable sound canberra)
$(use_enable acl)
+ $(use_enable crypt libsodium)
$(use_enable cscope)
$(use_enable gpm)
- $(use_enable lua luainterp)
- $(usex lua "--with-lua-prefix=${EPREFIX}/usr" "")
- $(use_with luajit)
$(use_enable nls)
$(use_enable perl perlinterp)
$(use_enable python python3interp)
- $(use_with python python3-command $(type -P $(eselect python show --python3)))
+ $(use_with python python3-command "${PYTHON}")
$(use_enable racket mzschemeinterp)
$(use_enable ruby rubyinterp)
$(use_enable selinux)
@@ -219,6 +230,18 @@ src_configure() {
'/# define FEAT_CSCOPE/d' src/feature.h || die "sed failed"
fi
+ if use lua; then
+ # -DLUA_COMPAT_OPENLIB=1 is required to enable the
+ # deprecated (in 5.1) luaL_openlib API (#874690)
+ use lua_single_target_lua5-1 && append-cppflags -DLUA_COMPAT_OPENLIB=1
+
+ myconf+=(
+ --enable-luainterp
+ $(use_with lua_single_target_luajit luajit)
+ --with-lua-prefix="${EPREFIX}/usr"
+ )
+ fi
+
# don't test USE=X here ... see bug #19115
# but need to provide a way to link against X ... see bug #20093
myconf+=(
@@ -234,6 +257,14 @@ src_configure() {
# keep prefix env contained within the EPREFIX
use prefix && myconf+=( --without-local-dir )
+ if tc-is-cross-compiler ; then
+ export vim_cv_getcwd_broken=no \
+ vim_cv_memmove_handles_overlap=yes \
+ vim_cv_stat_ignores_slash=yes \
+ vim_cv_terminfo=yes \
+ vim_cv_toupper_broken=no
+ fi
+
econf \
--with-modified-by=Gentoo-${PVR} \
"${myconf[@]}"
@@ -259,13 +290,39 @@ src_test() {
# Don't let vim talk to X
unset DISPLAY
+ # Arch and opensuse seem to do this and at this point, I'm willing
+ # to try anything to avoid random test hangs!
+ export TERM=xterm
+
+ # See https://github.com/vim/vim/blob/f08b0eb8691ff09f98bc4beef986ece1c521655f/src/testdir/runtest.vim#L5
+ # for more information on test variables we can use.
+ # Note that certain variables need vim-compatible regex (not PCRE), see e.g.
+ # http://www.softpanorama.org/Editors/Vimorama/vim_regular_expressions.shtml.
+ #
+ # Skipped tests:
+ # - Test_expand_star_star
+ # Hangs because of a recursive symlink in /usr/include/nodejs (bug #616680)
+ # - Test_exrc
+ # Looks in wrong location? (bug #742710)
+ # - Test_job_tty_in_out
+ # Fragile and depends on TERM(?)
+ # - Test_spelldump_bang
+ # Hangs.
+ # - Test_fuzzy_completion_env
+ # Too sensitive to leaked environment variables.
+ # - Test_term_mouse_multiple_clicks_to_select_mode
+ # Hangs.
+ # - Test_spelldump
+ # Hangs.
+ export TEST_SKIP_PAT='\(Test_expand_star_star\|Test_exrc\|Test_job_tty_in_out\|Test_spelldump_bang\|Test_fuzzy_completion_env\|Test_term_mouse_multiple_clicks_to_select_mode\|Test_spelldump\)'
+
emake -j1 -C src/testdir nongui
}
# Call eselect vi update with --if-unset
-# to respect user's choice (bug 187449)
+# to respect user's choice (bug #187449)
eselect_vi_update() {
- einfo "Calling eselect vi update..."
+ ebegin "Calling eselect vi update"
eselect vi update --if-unset
eend $?
}
@@ -276,7 +333,9 @@ src_install() {
# Note: Do not install symlinks for 'vi', 'ex', or 'view', as these are
# managed by eselect-vi
dobin src/vim
- dosym vim /usr/bin/vimdiff
+ if ! use minimal ; then
+ dosym vim /usr/bin/vimdiff
+ fi
dosym vim /usr/bin/rvim
dosym vim /usr/bin/rview
if use vim-pager ; then