summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/wxhexeditor')
-rw-r--r--app-editors/wxhexeditor/files/wxhexeditor-0.24-desktop.patch13
-rw-r--r--app-editors/wxhexeditor/metadata.xml3
-rw-r--r--app-editors/wxhexeditor/wxhexeditor-0.24-r2.ebuild (renamed from app-editors/wxhexeditor/wxhexeditor-0.24.ebuild)22
3 files changed, 28 insertions, 10 deletions
diff --git a/app-editors/wxhexeditor/files/wxhexeditor-0.24-desktop.patch b/app-editors/wxhexeditor/files/wxhexeditor-0.24-desktop.patch
new file mode 100644
index 000000000000..7d3d54da09ab
--- /dev/null
+++ b/app-editors/wxhexeditor/files/wxhexeditor-0.24-desktop.patch
@@ -0,0 +1,13 @@
+Index: resources/wxHexEditor.desktop
+===================================================================
+--- a/resources/wxHexEditor.desktop 2017-03-16 05:50:42.000000000 +0200
++++ b/resources/wxHexEditor.desktop 2017-03-24 12:16:39.931400635 +0200
+@@ -8,6 +8,7 @@ Exec=wxHexEditor
+ Icon=wxHexEditor
+ Terminal=false
+ Type=Application
+-Categories=Utility;TextEditor;Utility;
++Categories=Utility;TextEditor;
++Keywords=disk;drive;volume;harddisk;hdd;disc;cdrom;dvd;partition;iso;image;backup;restore;editor;
+ Keywords[en_GB]=disk;drive;volume;harddisk;hdd;disc;cdrom;dvd;partition;iso;image;backup;restore;editor;
+
diff --git a/app-editors/wxhexeditor/metadata.xml b/app-editors/wxhexeditor/metadata.xml
index 9065be762a9d..f5de54f05a07 100644
--- a/app-editors/wxhexeditor/metadata.xml
+++ b/app-editors/wxhexeditor/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>wxwidgets@gentoo.org</email>
@@ -7,5 +7,6 @@
</maintainer>
<upstream>
<remote-id type="sourceforge">wxhexeditor</remote-id>
+ <remote-id type="github">EUA/wxHexEditor</remote-id>
</upstream>
</pkgmetadata>
diff --git a/app-editors/wxhexeditor/wxhexeditor-0.24.ebuild b/app-editors/wxhexeditor/wxhexeditor-0.24-r2.ebuild
index 517f24a35eb8..f37ea1296050 100644
--- a/app-editors/wxhexeditor/wxhexeditor-0.24.ebuild
+++ b/app-editors/wxhexeditor/wxhexeditor-0.24-r2.ebuild
@@ -1,21 +1,19 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-WX_GTK_VER=3.0-gtk3
-
-inherit toolchain-funcs wxwidgets
+EAPI=8
MY_PN="wxHexEditor"
+WX_GTK_VER=3.0-gtk3
+inherit flag-o-matic toolchain-funcs wxwidgets
DESCRIPTION="A cross-platform hex editor designed specially for large files"
-HOMEPAGE="http://www.wxhexeditor.org/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-v${PV}-src.tar.xz"
+HOMEPAGE="https://github.com/EUA/wxHexEditor"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${MY_PN}-v${PV}-src.tar.xz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
+KEYWORDS="~amd64 ~riscv ~x86"
DEPEND="
app-crypt/mhash
@@ -27,6 +25,7 @@ S="${WORKDIR}/${MY_PN}"
PATCHES=(
"${FILESDIR}"/${P}-syslibs.patch
+ "${FILESDIR}"/${P}-desktop.patch
)
pkg_pretend() {
@@ -40,4 +39,9 @@ pkg_setup() {
src_prepare() {
setup-wxwidgets
default
+
+ # -Werror=odr, -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/854414
+ # https://github.com/EUA/wxHexEditor/issues/222
+ filter-lto
}