summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/fte/fte-20110708-r1.ebuild (renamed from app-editors/fte/fte-20110708.ebuild)38
1 files changed, 17 insertions, 21 deletions
diff --git a/app-editors/fte/fte-20110708.ebuild b/app-editors/fte/fte-20110708-r1.ebuild
index 19c53c6494b6..900419f10e31 100644
--- a/app-editors/fte/fte-20110708.ebuild
+++ b/app-editors/fte/fte-20110708-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI=6
inherit eutils toolchain-funcs
@@ -20,7 +20,7 @@ IUSE="gpm slang X"
S="${WORKDIR}/${PN}"
RDEPEND="
- >=sys-libs/ncurses-5.2
+ sys-libs/ncurses:0=
X? (
x11-libs/libXdmcp
x11-libs/libXau
@@ -32,6 +32,8 @@ DEPEND="${RDEPEND}
slang? ( >=sys-libs/slang-2.1.3 )
app-arch/unzip"
+HTML_DOCS=( doc/. )
+
set_targets() {
export TARGETS=""
use slang && TARGETS="${TARGETS} s${PN}"
@@ -43,14 +45,12 @@ set_targets() {
}
src_prepare() {
- # Do not apply anymore, posibly deprecated. TODO: Check and clean up.
- # epatch "${FILESDIR}"/${PN}-gcc34
- # epatch "${FILESDIR}"/${PN}-new_keyword.patch
- # epatch "${FILESDIR}"/${PN}-slang.patch
- # epatch "${FILESDIR}"/${PN}-interix.patch
+ default
- [[ -e /usr/include/linux/keyboard.h ]] && \
- sed /usr/include/linux/keyboard.h -e '/wait.h/d' > src/hacked_keyboard.h
+ if [[ -e "${EPREFIX}"/usr/include/linux/keyboard.h ]]; then
+ sed "${EPREFIX}"/usr/include/linux/keyboard.h \
+ -e '/wait.h/d' > src/hacked_keyboard.h || die
+ fi
sed \
-e "s:<linux/keyboard.h>:\"hacked_keyboard.h\":" \
@@ -90,35 +90,31 @@ src_compile() {
DEFAULT_FTE_CONFIG=../config/main.${PN} UOS=${os}"
set_targets
- emake CXX=$(tc-getCXX) OPTIMIZE="${CXXFLAGS}" ${DEFFLAGS} TARGETS="${TARGETS}" all
+ emake CXX="$(tc-getCXX)" OPTIMIZE="${CXXFLAGS}" "${DEFFLAGS}" TARGETS="${TARGETS}" all
}
src_install() {
- local files
-
keepdir /etc/${PN}
-
into /usr
set_targets
- files="${TARGETS} c${PN}"
+ local i files="${TARGETS} c${PN}"
for i in ${files}; do
- dobin src/$i
+ dobin src/${i}
done
- dobin "${FILESDIR}"/${PN}
+ dobin "${FILESDIR}/${PN}"
- dodoc BUGS README TODO
- dohtml doc/*
+ einstalldocs
insinto /usr/share/${PN}
- doins -r config/*
+ doins -r config/.
}
pkg_postinst() {
ebegin "Compiling configuration"
cd "${EPREFIX}"/usr/share/${PN} || die "missing configuration dir"
- "${EPREFIX}"/usr/bin/c${PN} main.${PN} "${EPREFIX}"/etc/${PN}/system.${PN}rc
+ "${EPREFIX}"/usr/bin/c${PN} main.${PN} "${EPREFIX}"/etc/${PN}/system.${PN}rc || die
eend $?
}