summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/apel')
-rw-r--r--app-emacs/apel/Manifest2
-rw-r--r--app-emacs/apel/apel-10.8-r1.ebuild52
-rw-r--r--app-emacs/apel/files/50apel-gentoo.el1
-rw-r--r--app-emacs/apel/files/apel-10.8-010_ikazuhiro.patch189
-rw-r--r--app-emacs/apel/files/apel-10.8-020_Prevent-fontset-error.patch32
-rw-r--r--app-emacs/apel/files/apel-10.8-040_make-temp-file-for-Emacs-24.3.50.patch27
-rw-r--r--app-emacs/apel/metadata.xml5
7 files changed, 308 insertions, 0 deletions
diff --git a/app-emacs/apel/Manifest b/app-emacs/apel/Manifest
new file mode 100644
index 000000000000..6a4f82134f2d
--- /dev/null
+++ b/app-emacs/apel/Manifest
@@ -0,0 +1,2 @@
+DIST apel-10.8-030_Use-new-style-backquotes.patch.gz 7869 SHA256 064edbe19f90e884ea2f5b64479e4498afacbb8d550c3882a4626bdf10a1bc98 SHA512 4074dc612feb2d63637bea2e9303423d4e9e035fad7f440d2da5331a6adc08f5ec61abb5087c2c4c72ec8931d1ccc4db3ffd061bcf3150d20c222c8df2e0b274 WHIRLPOOL f9bf88d85c5cdc8164bc0778bc5275c4e6c494f5927d11bcdf008851d7e2e70c32a3430a936abecc0239da1cf4a9b4a295ff7f4184a488462750f1dd8ac89363
+DIST apel-10.8.tar.gz 126326 SHA256 a511cc36bb51dc32b4915c9e03c67a994060b3156ceeab6fafa0be7874b9ccfe SHA512 39f13f15ec0a078d8f8dfe797899474cf4dfeb0bf7b8432a0c05bb38cf134d805c171a66b3d3efd074fbf294d68006d1e1d49903e45f1991d79cdcb4cca4aa9d WHIRLPOOL d222d3a477430b63e9a383a888fad0bc1871942830f462f505090495740028e517eac4052a72d0c00ea947308a6d75c0cade8ca12f76a81bd58f4643bf72f87d
diff --git a/app-emacs/apel/apel-10.8-r1.ebuild b/app-emacs/apel/apel-10.8-r1.ebuild
new file mode 100644
index 000000000000..2753f901a1d3
--- /dev/null
+++ b/app-emacs/apel/apel-10.8-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit elisp
+
+DESCRIPTION="A Portable Emacs Library is a library for making portable Emacs Lisp programs"
+HOMEPAGE="http://cvs.m17n.org/elisp/APEL/"
+SRC_URI="ftp://ftp.jpl.org/pub/elisp/apel/${P}.tar.gz
+ http://dev.gentoo.org/~gienah/2big4tree/app-emacs/${PN}/${PN}-10.8-030_Use-new-style-backquotes.patch.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE=""
+
+ELISP_PATCHES="${PN}-10.8-020_Prevent-fontset-error.patch
+ ${PN}-10.8-030_Use-new-style-backquotes.patch
+ ${PN}-10.8-010_ikazuhiro.patch
+ ${PN}-10.8-040_make-temp-file-for-Emacs-24.3.50.patch"
+
+src_prepare() {
+ elisp_src_prepare
+ cat <<-EOF >> APEL-CFG
+ (setq APEL_PREFIX "apel")
+ (setq EMU_PREFIX "apel")
+ EOF
+}
+
+src_compile() {
+ emake PREFIX="${ED}/usr" \
+ LISPDIR="${ED}/${SITELISP}" \
+ VERSION_SPECIFIC_LISPDIR="${ED}/${SITELISP}"
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" \
+ LISPDIR="${ED}/${SITELISP}" \
+ VERSION_SPECIFIC_LISPDIR="${ED}/${SITELISP}" \
+ install
+ elisp-site-file-install "${FILESDIR}/50apel-gentoo.el"
+ dodoc ChangeLog README*
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ elog "See the README.en file in /usr/share/doc/${PF} for tips"
+ elog "on how to customize this package."
+ elog "And you need to rebuild packages depending on ${PN}."
+}
diff --git a/app-emacs/apel/files/50apel-gentoo.el b/app-emacs/apel/files/50apel-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/apel/files/50apel-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/apel/files/apel-10.8-010_ikazuhiro.patch b/app-emacs/apel/files/apel-10.8-010_ikazuhiro.patch
new file mode 100644
index 000000000000..558939dee9fc
--- /dev/null
+++ b/app-emacs/apel/files/apel-10.8-010_ikazuhiro.patch
@@ -0,0 +1,189 @@
+--- apel-10.8-orig/ChangeLog 2013-10-03 18:17:05.176741628 +1000
++++ apel-10.8/ChangeLog 2013-10-03 18:16:54.442741731 +1000
+@@ -1,3 +1,56 @@
++2013-07-05 Tatsuya Kinoshita <tats@vega.ocn.ne.jp>
++
++ * mcs-20.el: Really check whether the mule-vesion variable is defined.
++
++2013-07-04 Kazuhiro Ito <kzhr@d1.dion.ne.jp>
++
++ * mcs-20.el: Check whether the mule-vesion variable is defined.
++ Cf. https://github.com/ikazuhiro/apel/commit/328c02e022340b36dd7e5f9250c7f86d2bafd793
++
++2013-03-24 Kazuhiro Ito <kzhr@d1.dion.ne.jp>
++
++ * mcs-20.el (mime-charset-to-coding-system): Display the message
++ and use charset name as coding system when
++ `mime-charset-coding-system-alist' indicates invalid coding
++ system.
++
++2012-09-07 Kazuhiro Ito <kzhr@d1.dion.ne.jp>
++
++ * mcs-e20.el (coding-system-to-mime-charset): Coding system's
++ setting is preferred to mime-charset-coding-system-alist's value.
++ Detect MIME name from mime-charset-coding-system-alist's value
++ more permissively.
++
++2012-08-08 Kazuhiro Ito <kzhr@d1.dion.ne.jp>
++
++ * poe.el (next-command-event): Fix that Emacs 21 and later were
++ treated as 'Emacs 19, 20.1 and 20.2'.
++
++2012-07-28 Kazuhiro Ito <kzhr@d1.dion.ne.jp>
++
++ * mcs-e20.el (charsets-mime-charset-alist): Do not use
++ `iso-2022-jp-2'.
++
++2012-07-28 Kazuhiro Ito <kzhr@d1.dion.ne.jp>
++
++ * mcs-20.el (detect-mime-charset-string): (Emacs23 and later) New
++ function.
++ (detect-mime-charset-region): Use it.
++
++2011-06-17 Kazuhiro Ito <kzhr@d1.dion.ne.jp>
++
++ * mcs-20.el (detect-mime-charset-region): (Emacs23 and later) Do
++ not check whether `charsets-mime-charset-alist' contains non
++ charset symbol.
++
++ * mcs-e20.el (charsets-mime-charset-alist): Remove non charset
++ symbol for Emacs 23 and later.
++
++2010-03-19 Kazuhiro Ito <kzhr@d1.dion.ne.jp>
++
++ * mcs-20.el (detect-mime-charset-region): Do not care priority of
++ charsets on Emacs 23 and later.
++
+ 2011-07-17 David Maus <dmaus@ictsoc.de>
+
+ * tinycustom.el (defcustom): Use new style backquotes.
+--- apel-10.8-orig/mcs-20.el 2005-07-06 12:08:52.000000000 +1000
++++ apel-10.8/mcs-20.el 2013-10-03 17:44:42.936760151 +1000
+@@ -84,11 +84,13 @@
+ (if (stringp charset)
+ (setq charset (intern (downcase charset)))
+ )
+- (let ((cs (assq charset mime-charset-coding-system-alist)))
+- (setq cs
+- (if cs
+- (cdr cs)
+- charset))
++ (let ((cs (cdr (assq charset mime-charset-coding-system-alist))))
++ (unless (or (null cs) (find-coding-system cs))
++ (message
++ "Invalid coding system: %s. Confirm mime-charset-coding-system-alist."
++ cs)
++ (setq cs nil))
++ (unless cs (setq cs charset))
+ (if lbt
+ (setq cs (intern (format "%s-%s" cs
+ (cond ((eq lbt 'CRLF) 'dos)
+@@ -96,12 +98,11 @@
+ ((eq lbt 'CR) 'mac)
+ (t lbt)))))
+ )
+- (if (find-coding-system cs)
+- cs
+- (if mime-charset-to-coding-system-default-method
+- (funcall mime-charset-to-coding-system-default-method
+- charset lbt cs)
+- ))))
++ (or (find-coding-system cs)
++ (if mime-charset-to-coding-system-default-method
++ (funcall mime-charset-to-coding-system-default-method
++ charset lbt cs)
++ ))))
+
+ (defalias 'mime-charset-p 'mime-charset-to-coding-system)
+
+@@ -209,6 +210,34 @@
+ (setq rest (cdr rest)))
+ default-mime-charset-for-write)))
+ )
++
++((eval-when-compile (and (boundp 'mule-version)
++ (null (string< mule-version "6.0"))))
++;; for Emacs 23 and later
++(defun detect-mime-charset-string (string)
++ "Return MIME charset for STRING."
++ (let ((src (string-to-list string))
++ tmp)
++ (setq tmp src)
++ ;; Uniquify the list of characters.
++ (while tmp
++ (setq tmp (setcdr tmp (delq (car tmp) (cdr tmp)))))
++ ;; Detect charset from the list of characters.
++ (catch 'found
++ (mapc (lambda (cons)
++ (catch 'next
++ (mapc (lambda (ch) (unless (char-charset ch (car cons))
++ (throw 'next nil)))
++ src)
++ (throw 'found (cdr cons))))
++ charsets-mime-charset-alist)
++ default-mime-charset-for-write)))
++
++(defsubst detect-mime-charset-region (start end)
++ "Return MIME charset for region between START and END."
++ (detect-mime-charset-string
++ (buffer-substring-no-properties start end))))
++
+ (t
+ ;; for legacy Mule
+ (defun detect-mime-charset-region (start end)
+--- apel-10.8-orig/mcs-e20.el 2005-07-06 12:08:52.000000000 +1000
++++ apel-10.8/mcs-e20.el 2013-10-03 17:44:42.936760151 +1000
+@@ -90,11 +90,15 @@
+ ((ascii korean-ksc5601) . euc-kr)
+ ((ascii chinese-gb2312) . gb2312)
+ ((ascii chinese-big5-1 chinese-big5-2) . big5)
+- ((ascii thai-tis620 composition) . tis-620)
+- ((ascii latin-iso8859-1 greek-iso8859-7
+- latin-jisx0201 japanese-jisx0208-1978
+- chinese-gb2312 japanese-jisx0208
+- korean-ksc5601 japanese-jisx0212) . iso-2022-jp-2)
++ ,(static-cond
++ ((null (string< mule-version "6.0"))
++ '((ascii thai-tis620) . tis-620))
++ (t
++ '((ascii thai-tis620 composition) . tis-620)))
++ ;; ((ascii latin-iso8859-1 greek-iso8859-7
++ ;; latin-jisx0201 japanese-jisx0208-1978
++ ;; chinese-gb2312 japanese-jisx0208
++ ;; korean-ksc5601 japanese-jisx0212) . iso-2022-jp-2)
+ ;;((ascii latin-iso8859-1 greek-iso8859-7
+ ;; latin-jisx0201 japanese-jisx0208-1978
+ ;; chinese-gb2312 japanese-jisx0208
+@@ -119,8 +123,16 @@
+ (defun coding-system-to-mime-charset (coding-system)
+ "Convert CODING-SYSTEM to a MIME-charset.
+ Return nil if corresponding MIME-charset is not found."
+- (or (car (rassq coding-system mime-charset-coding-system-alist))
+- (coding-system-get coding-system 'mime-charset)
++ (or (coding-system-get coding-system 'mime-charset)
++ (let ((coding (coding-system-base coding-system))
++ (alist mime-charset-coding-system-alist)
++ result)
++ (while alist
++ (if (eq (coding-system-base (cdar alist)) coding)
++ (setq result (caar alist)
++ alist nil)
++ (setq alist (cdr alist))))
++ result)
+ ))
+
+ (defun-maybe-cond mime-charset-list ()
+--- apel-10.8-orig/poe.el 2013-10-03 17:43:11.327761025 +1000
++++ apel-10.8/poe.el 2013-10-03 17:44:42.937760151 +1000
+@@ -1996,8 +1996,9 @@
+ returned.
+ If PROMPT is non-nil, it should be a string and will be displayed in
+ the echo area while this function is waiting for an event."
+- ((and (>= emacs-major-version 20)
+- (>= emacs-minor-version 4))
++ ((or (>= emacs-major-version 21)
++ (and (>= emacs-major-version 20)
++ (>= emacs-minor-version 4)))
+ ;; Emacs 20.4 and later.
+ (read-event prompt)) ; should specify 2nd arg?
+ ((and (= emacs-major-version 20)
diff --git a/app-emacs/apel/files/apel-10.8-020_Prevent-fontset-error.patch b/app-emacs/apel/files/apel-10.8-020_Prevent-fontset-error.patch
new file mode 100644
index 000000000000..9cea1e675276
--- /dev/null
+++ b/app-emacs/apel/files/apel-10.8-020_Prevent-fontset-error.patch
@@ -0,0 +1,32 @@
+Description: Prevent an error of fontset-pixel-size for Emacs 23.
+Bug-Debian: http://bugs.debian.org/477177
+Author: Tatsuya Kinoshita <tats@debian.org>
+
+--- a/ChangeLog
++++ b/ChangeLog
+@@ -0,0 +1,5 @@
++2010-02-14 Tatsuya Kinoshita <tats@vega.ocn.ne.jp>
++
++ * poem-e20.el (fontset-pixel-size): Don't cause an error. Workaround
++ for Emacs 23.
++
+--- a/poem-e20.el
++++ b/poem-e20.el
+@@ -25,6 +25,7 @@
+ ;;; Code:
+
+ (defun fontset-pixel-size (fontset)
++ (condition-case nil
+ (let* ((info (fontset-info fontset))
+ (height (aref info 1))
+ )
+@@ -32,7 +33,8 @@
+ ((string-match "-\\([0-9]+\\)-" fontset)
+ (string-to-number
+ (substring fontset (match-beginning 1)(match-end 1))))
+- (t 0))))
++ (t 0)))
++ (error 0)))
+
+
+ ;;; @ character set
diff --git a/app-emacs/apel/files/apel-10.8-040_make-temp-file-for-Emacs-24.3.50.patch b/app-emacs/apel/files/apel-10.8-040_make-temp-file-for-Emacs-24.3.50.patch
new file mode 100644
index 000000000000..30b0abc8ef77
--- /dev/null
+++ b/app-emacs/apel/files/apel-10.8-040_make-temp-file-for-Emacs-24.3.50.patch
@@ -0,0 +1,27 @@
+Subject: Fix wrong type argument on Emacs 24.3.50 to check make-temp-file
+From: Tatsuya Kinoshita <tats@debian.org>
+Bug-Debian: http://bugs.debian.org/718765
+
+diff --git a/ChangeLog b/ChangeLog
+index 8e96224..9505b2e 100644
+--- a/ChangeLog
++++ b/ChangeLog
+@@ -0,0 +1,5 @@
++2013-08-05 Tatsuya Kinoshita <tats@vega.ocn.ne.jp>
++
++ * poe.el: Fix wrong type argument on Emacs 24.3.50 to check
++ `make-temp-file'.
++
+diff --git a/poe.el b/poe.el
+index be52847..b381f90 100644
+--- a/poe.el
++++ b/poe.el
+@@ -1667,7 +1667,7 @@ See `walk-windows' for the meaning of MINIBUF and FRAME."
+ )))
+ ;; arglist: (prefix &optional dir-flag suffix)
+ (cond
+- ((not arglist)
++ ((or (not arglist) (not (listp arglist)))
+ ;; `make-temp-file' is a built-in; expects 3-args.
+ (put 'make-temp-file 'defun-maybe '3-args))
+ ((> (length arglist) 3)
diff --git a/app-emacs/apel/metadata.xml b/app-emacs/apel/metadata.xml
new file mode 100644
index 000000000000..bc306fe58224
--- /dev/null
+++ b/app-emacs/apel/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>