summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/apel')
-rw-r--r--app-emacs/apel/apel-10.8-r1.ebuild7
-rw-r--r--app-emacs/apel/files/apel-10.8-050_escape-backslash.patch20
2 files changed, 24 insertions, 3 deletions
diff --git a/app-emacs/apel/apel-10.8-r1.ebuild b/app-emacs/apel/apel-10.8-r1.ebuild
index 7559be4d453d..8fbddf334241 100644
--- a/app-emacs/apel/apel-10.8-r1.ebuild
+++ b/app-emacs/apel/apel-10.8-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=6
inherit elisp
@@ -18,7 +18,8 @@ IUSE=""
ELISP_PATCHES="${PN}-10.8-020_Prevent-fontset-error.patch
${PN}-10.8-030_Use-new-style-backquotes.patch
${PN}-10.8-010_ikazuhiro.patch
- ${PN}-10.8-040_make-temp-file-for-Emacs-24.3.50.patch"
+ ${PN}-10.8-040_make-temp-file-for-Emacs-24.3.50.patch
+ ${PN}-10.8-050_escape-backslash.patch"
src_prepare() {
elisp_src_prepare
diff --git a/app-emacs/apel/files/apel-10.8-050_escape-backslash.patch b/app-emacs/apel/files/apel-10.8-050_escape-backslash.patch
new file mode 100644
index 000000000000..a2892d303b37
--- /dev/null
+++ b/app-emacs/apel/files/apel-10.8-050_escape-backslash.patch
@@ -0,0 +1,20 @@
+--- a/poe.el 2018-07-27 19:34:05.959194677 -0500
++++ b/poe.el 2018-07-27 19:40:06.409212629 -0500
+@@ -1081,7 +1081,7 @@
+ If third arg LITERAL is non-nil, insert NEWTEXT literally.
+ Otherwise treat `\' as special:
+ `\&' in NEWTEXT means substitute original matched text.
+- `\N' means substitute what matched the Nth `\(...\)'.
++ `\\N' means substitute what matched the Nth `\(...\)'.
+ If Nth parens didn't match, substitute nothing.
+ `\\' means insert one `\'.
+ FIXEDCASE and LITERAL are optional arguments.
+@@ -1133,7 +1133,7 @@
+ If third arg LITERAL is non-nil, insert NEWTEXT literally.
+ Otherwise treat `\' as special:
+ `\&' in NEWTEXT means substitute original matched text.
+- `\N' means substitute what matched the Nth `\(...\)'.
++ `\\N' means substitute what matched the Nth `\(...\)'.
+ If Nth parens didn't match, substitute nothing.
+ `\\' means insert one `\'.
+ FIXEDCASE and LITERAL are optional arguments.