summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/async/async-1.9.8.ebuild')
-rw-r--r--app-emacs/async/async-1.9.8.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-emacs/async/async-1.9.8.ebuild b/app-emacs/async/async-1.9.8.ebuild
new file mode 100644
index 000000000000..62b8d1e0a482
--- /dev/null
+++ b/app-emacs/async/async-1.9.8.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+MY_P="emacs-async-${PV}"
+DESCRIPTION="Simple library for asynchronous processing in Emacs"
+HOMEPAGE="https://github.com/jwiegley/emacs-async"
+SRC_URI="https://github.com/jwiegley/emacs-async/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+SITEFILE="50${PN}-gentoo.el"
+DOCS="README.md"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}