summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/autothemer/autothemer-0.2.18.ebuild')
-rw-r--r--app-emacs/autothemer/autothemer-0.2.18.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/app-emacs/autothemer/autothemer-0.2.18.ebuild b/app-emacs/autothemer/autothemer-0.2.18.ebuild
index 9ed03806642f..6536dcad1efa 100644
--- a/app-emacs/autothemer/autothemer-0.2.18.ebuild
+++ b/app-emacs/autothemer/autothemer-0.2.18.ebuild
@@ -9,12 +9,17 @@ inherit elisp
DESCRIPTION="Conveniently define themes for GNU Emacs"
HOMEPAGE="https://github.com/jasonm23/autothemer"
-# Recompressed from NonGNU ELPA.
-SRC_URI="https://dev.gentoo.org/~arsen/${P}.tar.xz"
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jasonm23/autothemer.git"
+else
+ # Recompressed from NonGNU ELPA.
+ SRC_URI="https://dev.gentoo.org/~arsen/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS="~amd64"
RDEPEND="
>=app-emacs/dash-2.10.0
@@ -30,4 +35,4 @@ DOCS=(
function-reference.md
)
-elisp-enable-tests ert "${S}"/tests -l "${PN}"-tests.el
+elisp-enable-tests ert "${S}"/tests -l tests/"${PN}"-tests.el