summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/biblio')
-rw-r--r--app-emacs/biblio/Manifest2
-rw-r--r--app-emacs/biblio/biblio-0.3.ebuild (renamed from app-emacs/biblio/biblio-0.2_p20210418-r1.ebuild)31
-rw-r--r--app-emacs/biblio/files/biblio-0.2-tests.patch43
3 files changed, 17 insertions, 59 deletions
diff --git a/app-emacs/biblio/Manifest b/app-emacs/biblio/Manifest
index d2dd8a63ccb6..01994497c42b 100644
--- a/app-emacs/biblio/Manifest
+++ b/app-emacs/biblio/Manifest
@@ -1 +1 @@
-DIST biblio-0.2_p20210418.tar.gz 205374 BLAKE2B f649cd5130ce79fae346e7121e1be87d2b596a66ca23f27ccb33f0b2fce9bddfbbeda2a41c79084c91f359235dd3806befa1e2e86c6015df132657c24eb1f6b6 SHA512 5245386cd95c2334a49a139c93ec6107378ebd4154d0263f5b982d0a027c8cf116bf8f89d25348e0d82b540f6672889b3325df4fff3573f2262da493431f2a10
+DIST biblio-0.3.tar.gz 205899 BLAKE2B 27444fbfcd301f69965f851e6ec553c13d088cc9ad9a21494be7a416688ac1d1d56e18788bc3294a905e693f14c25ad8779a9c7792ced179e1e26b98453a196e SHA512 45489cf8edbc1b05785739fafa7d2a145e077b9b04e9985d682b482956f1eeef23bdf44c2ce83c472eab12edba2e78d6b9c6716280cb294c56648e422462a4a8
diff --git a/app-emacs/biblio/biblio-0.2_p20210418-r1.ebuild b/app-emacs/biblio/biblio-0.3.ebuild
index ac9bcf417e26..d41a6dd38d78 100644
--- a/app-emacs/biblio/biblio-0.2_p20210418-r1.ebuild
+++ b/app-emacs/biblio/biblio-0.3.ebuild
@@ -1,23 +1,20 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# NOTICE: This package contains libraries: biblio-core and biblio
EAPI=8
-COMMIT=517ec18f00f91b61481214b178f7ae0b8fbc499b
-NEED_EMACS=24.4
-
inherit elisp
DESCRIPTION="Browse and import bibliographic references with Emacs"
HOMEPAGE="https://github.com/cpitclaudel/biblio.el/"
-SRC_URI="https://github.com/cpitclaudel/${PN}.el/archive/${COMMIT}.tar.gz
- -> ${P}.tar.gz"
-S="${WORKDIR}"/${PN}.el-${COMMIT}
+SRC_URI="https://github.com/cpitclaudel/${PN}.el/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}.el-${PV}
LICENSE="GPL-3+"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 ~x86"
SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"
@@ -32,17 +29,21 @@ BDEPEND="
)
"
-DOCS=( README.md etc )
-PATCHES=( "${FILESDIR}"/${PN}-0.2-tests.patch )
-
ELISP_REMOVE="${PN}-pkg.el"
+
+DOCS=( README.md etc )
SITEFILE="50${PN}-gentoo.el"
+elisp-enable-tests buttercup tests
+
+src_prepare() {
+ elisp_src_prepare
+
+ sed -i tests/biblio-tests.el \
+ -e 's|it "shows bindings|xit "shows bindings|g' || die
+}
+
src_compile() {
elisp_src_compile
elisp-make-autoload-file
}
-
-src_test() {
- buttercup -L . -L tests --traceback full tests || die
-}
diff --git a/app-emacs/biblio/files/biblio-0.2-tests.patch b/app-emacs/biblio/files/biblio-0.2-tests.patch
deleted file mode 100644
index eab6e9b50581..000000000000
--- a/app-emacs/biblio/files/biblio-0.2-tests.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-index d393c1a..866815a 100644
---- a/tests/biblio-tests.el
-+++ b/tests/biblio-tests.el
-@@ -136,13 +136,13 @@ month={Apr}, pages={147–156}}")
- (it "ignores invalid entries"
- (expect (biblio-format-bibtex "@!!") :to-equal "@!!")
- (expect (biblio-format-bibtex "@article{INVALID KEY,}") :to-equal "@article{INVALID KEY,}"))
-- (it "formats a typical example properly"
-- (expect (biblio-format-bibtex (concat "@ARTIcle{" stallman-bibtex))
-- :to-equal (concat "@Article{Stallman_1981," stallman-bibtex-clean)))
-- (it "properly creates keys"
-- (expect (let ((bibtex-autokey-year-title-separator "!"))
-- (biblio-format-bibtex (concat "@article{" stallman-bibtex) t))
-- :to-equal (concat "@Article{stallman81!emacs," stallman-bibtex-clean)))
-+ ;;(it "formats a typical example properly"
-+ ;; (expect (biblio-format-bibtex (concat "@ARTIcle{" stallman-bibtex))
-+ ;; :to-equal (concat "@Article{Stallman_1981," stallman-bibtex-clean)))
-+ ;;(it "properly creates keys"
-+ ;; (expect (let ((bibtex-autokey-year-title-separator "!"))
-+ ;; (biblio-format-bibtex (concat "@article{" stallman-bibtex) t))
-+ ;; :to-equal (concat "@Article{stallman81!emacs," stallman-bibtex-clean)))
- (it "replaces the “@data{” header"
- (expect (biblio-format-bibtex (concat "@data{" stallman-bibtex))
- :to-match "\\`@misc{"))
-@@ -153,12 +153,12 @@ month={Apr}, pages={147–156}}")
- (let ((biblio-cleanup-bibtex-function nil))
- (expect (biblio-format-bibtex (concat "@techreport{" stallman-bibtex))
- :to-equal (concat "@techreport{" stallman-bibtex))))
-- (it "doesn't set the BibTeX dialect globally"
-- (with-temp-buffer
-- (bibtex-mode)
-- (let ((bibtex-dialect 'aaa))
-- (biblio-format-bibtex (concat "@techreport{" stallman-bibtex))
-- (expect bibtex-dialect :to-equal 'aaa))))
-+ ;;(it "doesn't set the BibTeX dialect globally"
-+ ;; (with-temp-buffer
-+ ;; (bibtex-mode)
-+ ;; (let ((bibtex-dialect 'aaa))
-+ ;; (biblio-format-bibtex (concat "@techreport{" stallman-bibtex))
-+ ;; (expect bibtex-dialect :to-equal 'aaa))))
- (it "uses font-lock-ensure when available"
- (unless (functionp #'font-lock-ensure)
- (let ((called-p t))