summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/cape/cape-9999.ebuild')
-rw-r--r--app-emacs/cape/cape-9999.ebuild25
1 files changed, 13 insertions, 12 deletions
diff --git a/app-emacs/cape/cape-9999.ebuild b/app-emacs/cape/cape-9999.ebuild
index f7f6e19f558b..42896ab1f608 100644
--- a/app-emacs/cape/cape-9999.ebuild
+++ b/app-emacs/cape/cape-9999.ebuild
@@ -4,19 +4,19 @@
EAPI=8
NEED_EMACS=27.1
+
inherit elisp
DESCRIPTION="Completion At Point Extensions"
-HOMEPAGE="https://github.com/minad/cape"
+HOMEPAGE="https://github.com/minad/cape/"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/minad/cape.git"
+ EGIT_REPO_URI="https://github.com/minad/${PN}.git"
else
- # Recompressed from ELPA.
- SRC_URI="https://dev.gentoo.org/~arsen/${P}.tar.xz"
+ SRC_URI="https://github.com/minad/${PN}/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.tar.gz"
KEYWORDS="~amd64"
- ELISP_REMOVE="${PN}-pkg.el"
fi
LICENSE="GPL-3+"
@@ -25,15 +25,16 @@ SLOT="0"
RDEPEND="
>=app-emacs/compat-29.1.4.0
"
-DEPEND="${RDEPEND}"
+DEPEND="
+ ${RDEPEND}
+"
+DOCS=( CHANGELOG.org README.org )
+ELISP_TEXINFO="${PN}.texi"
SITEFILE="50${PN}-gentoo.el"
-src_install() {
+src_compile() {
+ elisp-org-export-to texinfo README.org
+ elisp_src_compile
elisp-make-autoload-file
- elisp_src_install
-
- if [[ ${PV} != 9999 ]]; then
- doinfo cape.info
- fi
}