summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/cmake-font-lock/cmake-font-lock-0.1.13-r1.ebuild')
-rw-r--r--app-emacs/cmake-font-lock/cmake-font-lock-0.1.13-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-emacs/cmake-font-lock/cmake-font-lock-0.1.13-r1.ebuild b/app-emacs/cmake-font-lock/cmake-font-lock-0.1.13-r1.ebuild
new file mode 100644
index 000000000000..4625030d159c
--- /dev/null
+++ b/app-emacs/cmake-font-lock/cmake-font-lock-0.1.13-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26
+
+inherit elisp
+
+DESCRIPTION="Advanced, type aware, highlight support for CMake"
+HOMEPAGE="https://github.com/Lindydancer/cmake-font-lock"
+SRC_URI="https://github.com/Lindydancer/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ || (
+ app-emacs/cmake-mode
+ dev-build/cmake[emacs(-)]
+ )
+"
+BDEPEND="${RDEPEND}"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}