summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/corfu')
-rw-r--r--app-emacs/corfu/Manifest2
-rw-r--r--app-emacs/corfu/corfu-1.3.ebuild39
-rw-r--r--app-emacs/corfu/corfu-1.4.ebuild39
-rw-r--r--app-emacs/corfu/corfu-9999.ebuild39
-rw-r--r--app-emacs/corfu/files/50corfu-gentoo.el2
-rw-r--r--app-emacs/corfu/metadata.xml12
6 files changed, 133 insertions, 0 deletions
diff --git a/app-emacs/corfu/Manifest b/app-emacs/corfu/Manifest
new file mode 100644
index 000000000000..d69ba3e686fd
--- /dev/null
+++ b/app-emacs/corfu/Manifest
@@ -0,0 +1,2 @@
+DIST corfu-1.3.tar.gz 49907 BLAKE2B 18fbd99fa6d744bf3ad82abf647447770916b84d15ef1a44d4cdc406975ec0c035e75fc5234ce6e13f21840567ad1d574acd25a774585b42522491cdefa93bd6 SHA512 c21962572a101b6e5dd654ac058dd534b450840a97b6d4029b191ddce10a9c6bfc9e631e969ce15789e4fb71ccad66dde509a4c1a7f30a2669327ee84c706987
+DIST corfu-1.4.tar.gz 49929 BLAKE2B 7735675c243e7b05793cb0fe7f74b6417a42668d7bea8b17c14afd00b724f1e0dea85207aea628b5f54afb81e048bc860913156839c3eb9588c2d702ba4bf3e4 SHA512 78028d77adfe456ee71d18bd818980bbe9293b91ad746878c669362f6b22273622a999a291923c79b73244830d45ac4af3c4fa26459e3ffd4877145b3804d636
diff --git a/app-emacs/corfu/corfu-1.3.ebuild b/app-emacs/corfu/corfu-1.3.ebuild
new file mode 100644
index 000000000000..d8351fe993cc
--- /dev/null
+++ b/app-emacs/corfu/corfu-1.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Completion Overlay Region FUnction"
+HOMEPAGE="https://github.com/minad/corfu/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+else
+ SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND=">=app-emacs/compat-29.1.3.4"
+BDEPEND="${RDEPEND}"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ default
+ mv extensions/*.el . || die
+}
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}
diff --git a/app-emacs/corfu/corfu-1.4.ebuild b/app-emacs/corfu/corfu-1.4.ebuild
new file mode 100644
index 000000000000..d8351fe993cc
--- /dev/null
+++ b/app-emacs/corfu/corfu-1.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Completion Overlay Region FUnction"
+HOMEPAGE="https://github.com/minad/corfu/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+else
+ SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND=">=app-emacs/compat-29.1.3.4"
+BDEPEND="${RDEPEND}"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ default
+ mv extensions/*.el . || die
+}
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}
diff --git a/app-emacs/corfu/corfu-9999.ebuild b/app-emacs/corfu/corfu-9999.ebuild
new file mode 100644
index 000000000000..e1bbf4ca3ef1
--- /dev/null
+++ b/app-emacs/corfu/corfu-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Completion Overlay Region FUnction"
+HOMEPAGE="https://github.com/minad/corfu/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+else
+ SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND=">=app-emacs/compat-29.1.3.4"
+BDEPEND="${RDEPEND}"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ default
+ mv extensions/*.el . || die
+}
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}
diff --git a/app-emacs/corfu/files/50corfu-gentoo.el b/app-emacs/corfu/files/50corfu-gentoo.el
new file mode 100644
index 000000000000..e80eb907bae9
--- /dev/null
+++ b/app-emacs/corfu/files/50corfu-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "@SITELISP@/corfu-autoloads" nil t)
diff --git a/app-emacs/corfu/metadata.xml b/app-emacs/corfu/metadata.xml
new file mode 100644
index 000000000000..ab95b8c63633
--- /dev/null
+++ b/app-emacs/corfu/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<stabilize-allarches/>
+<upstream>
+ <remote-id type="github">minad/corfu</remote-id>
+</upstream>
+</pkgmetadata>