summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/crux/crux-0.4.0.ebuild')
-rw-r--r--app-emacs/crux/crux-0.4.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-emacs/crux/crux-0.4.0.ebuild b/app-emacs/crux/crux-0.4.0.ebuild
new file mode 100644
index 000000000000..29a1dfdebb87
--- /dev/null
+++ b/app-emacs/crux/crux-0.4.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Collection of Ridiculously Useful eXtensions for GNU Emacs"
+HOMEPAGE="https://github.com/bbatsov/crux/"
+SRC_URI="https://github.com/bbatsov/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}