summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/crux/crux-0.5.0.ebuild')
-rw-r--r--app-emacs/crux/crux-0.5.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-emacs/crux/crux-0.5.0.ebuild b/app-emacs/crux/crux-0.5.0.ebuild
new file mode 100644
index 000000000000..dcc16069ffc5
--- /dev/null
+++ b/app-emacs/crux/crux-0.5.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+
+inherit elisp
+
+DESCRIPTION="Collection of Ridiculously Useful eXtensions for GNU Emacs"
+HOMEPAGE="https://github.com/bbatsov/crux/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/bbatsov/${PN}.git"
+else
+ SRC_URI="https://github.com/bbatsov/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}