summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/csharp-mode/csharp-mode-2.0.0.ebuild')
-rw-r--r--app-emacs/csharp-mode/csharp-mode-2.0.0.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/app-emacs/csharp-mode/csharp-mode-2.0.0.ebuild b/app-emacs/csharp-mode/csharp-mode-2.0.0.ebuild
index 38b6550b6d21..047ba7f86bb7 100644
--- a/app-emacs/csharp-mode/csharp-mode-2.0.0.ebuild
+++ b/app-emacs/csharp-mode/csharp-mode-2.0.0.ebuild
@@ -7,7 +7,8 @@ inherit elisp
DESCRIPTION="A derived Emacs mode implementing most of the C# rules"
HOMEPAGE="https://github.com/emacs-csharp/csharp-mode"
-SRC_URI="https://github.com/emacs-csharp/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/emacs-csharp/${PN}/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
@@ -17,3 +18,12 @@ RESTRICT="test" # tries to install an old version of dash from the network
DOCS=( README.org )
ELISP_REMOVE="csharp-mode-tests.el" # useless since we can not run tests
SITEFILE="50${PN}-gentoo.el"
+
+pkg_setup() {
+ elisp_pkg_setup
+
+ if ver_test "$(elisp-emacs-version)" -ge 29 ; then
+ ewarn "csharp-mode is included in GNU Emacs >=29,"
+ ewarn "Emacs developers recommend that you use the provided mode instead."
+ fi
+}