summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/demap')
-rw-r--r--app-emacs/demap/Manifest1
-rw-r--r--app-emacs/demap/demap-1.4.0.ebuild23
-rw-r--r--app-emacs/demap/files/50demap-gentoo.el3
-rw-r--r--app-emacs/demap/metadata.xml25
4 files changed, 52 insertions, 0 deletions
diff --git a/app-emacs/demap/Manifest b/app-emacs/demap/Manifest
new file mode 100644
index 000000000000..cd10a00d2319
--- /dev/null
+++ b/app-emacs/demap/Manifest
@@ -0,0 +1 @@
+DIST demap.el-v1.4.0.tar.gz 26998 BLAKE2B 410cb79fffbe562861c2c91d3a8284303ae71edf5a3c331bd0c86b1aef7cfa18c731853c425bf208073da26815651e02e49faa2f93eeb667f53cf6c0a1920f08 SHA512 4f21e9135645df17fbb9a0d2f8031ad6ab0af23af9c8f4744c1510a534ea7c518bc6d0be4801484121b040e952f182d0b70dc3505e4e7534114f53a1e8ae1723
diff --git a/app-emacs/demap/demap-1.4.0.ebuild b/app-emacs/demap/demap-1.4.0.ebuild
new file mode 100644
index 000000000000..ff9e6adcef03
--- /dev/null
+++ b/app-emacs/demap/demap-1.4.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Detachable minimap for Emacs"
+HOMEPAGE="https://gitlab.com/sawyerjgardner/demap.el/"
+SRC_URI="https://gitlab.com/sawyerjgardner/${PN}.el/-/archive/v${PV}/${PN}.el-v${PV}.tar.gz"
+S="${WORKDIR}"/${PN}.el-v${PV}
+
+LICENSE="GPL-3+"
+KEYWORDS="amd64 x86"
+SLOT="0"
+
+# "make test" is just a practical check if "demap-open" works, maintainers of
+# this package could check themselves if it still works after installation.
+# Notice that we autolaod only the "demap-toggle" function (not "demap-open").
+RESTRICT="test"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/demap/files/50demap-gentoo.el b/app-emacs/demap/files/50demap-gentoo.el
new file mode 100644
index 000000000000..bcd35f5b7298
--- /dev/null
+++ b/app-emacs/demap/files/50demap-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'demap-toggle "demap"
+ "Toggle side window showing a minimap." t)
diff --git a/app-emacs/demap/metadata.xml b/app-emacs/demap/metadata.xml
new file mode 100644
index 000000000000..0f222a2cdbbf
--- /dev/null
+++ b/app-emacs/demap/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ demap.el adds a minimap that shows a zoomed out view of the active window's
+ buffer. You can toggle showing the minimap in a side window with
+ "demap-toggle". This package has a few advantages over other minimap
+ packages: support for detaching minimaps and having them on a different
+ frame then the active window; support for multiple minimap buffers, with
+ their own buffer local definitions on what buffers it can show and how to
+ show them; having the minimap on the side of the frame rather then on the
+ side of the active window by default.
+ </longdescription>
+ <upstream>
+ <changelog>https://gitlab.com/sawyerjgardner/demap.el/-/releases/</changelog>
+ <bugs-to>https://gitlab.com/sawyerjgardner/demap.el/-/issues/</bugs-to>
+ <remote-id type="gitlab">sawyerjgardner/demap.el</remote-id>
+ </upstream>
+ <stabilize-allarches />
+</pkgmetadata>