summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/earthfile-mode')
-rw-r--r--app-emacs/earthfile-mode/Manifest1
-rw-r--r--app-emacs/earthfile-mode/earthfile-mode-0.1.0_p20230810.ebuild28
-rw-r--r--app-emacs/earthfile-mode/files/50earthfile-mode-gentoo.el5
-rw-r--r--app-emacs/earthfile-mode/metadata.xml14
4 files changed, 48 insertions, 0 deletions
diff --git a/app-emacs/earthfile-mode/Manifest b/app-emacs/earthfile-mode/Manifest
new file mode 100644
index 000000000000..66f237fa143c
--- /dev/null
+++ b/app-emacs/earthfile-mode/Manifest
@@ -0,0 +1 @@
+DIST earthfile-mode-0.1.0_p20230810.tar.gz 397227 BLAKE2B 5d233689dff77debfafd77e2ee8d260ba993d2e19778d741750b79faa35d1553f6c1aeec00d5753547f6ce77a7ec01dc0117dd60418812d2eeadcc39fae71b42 SHA512 3d7d444ac441eaa2ced603f38fcbecad41abe55ca85c1d085ab45c534065e5afe8c2fc902e6334f28b38042e358de043917fb1e940628d63a34dc35a153720ef
diff --git a/app-emacs/earthfile-mode/earthfile-mode-0.1.0_p20230810.ebuild b/app-emacs/earthfile-mode/earthfile-mode-0.1.0_p20230810.ebuild
new file mode 100644
index 000000000000..881895441851
--- /dev/null
+++ b/app-emacs/earthfile-mode/earthfile-mode-0.1.0_p20230810.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+[[ "${PV}" == *20230810 ]] && COMMIT=3029e5ab06171ca5947041e95053561e10e5ba41
+
+inherit elisp
+
+DESCRIPTION="GNU Emacs major mode for editing Earthly Earthfiles"
+HOMEPAGE="https://github.com/earthly/earthly-emacs/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/earthly/earthly-emacs.git"
+else
+ SRC_URI="https://github.com/earthly/earthly-emacs/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/earthly-emacs-${COMMIT}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MPL-2.0"
+SLOT="0"
+
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/earthfile-mode/files/50earthfile-mode-gentoo.el b/app-emacs/earthfile-mode/files/50earthfile-mode-gentoo.el
new file mode 100644
index 000000000000..b43ef6dbef1e
--- /dev/null
+++ b/app-emacs/earthfile-mode/files/50earthfile-mode-gentoo.el
@@ -0,0 +1,5 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'earthfile-mode "earthfile-mode.el"
+ "A major mode for editing Earthfile file." t)
+(add-to-list 'auto-mode-alist '("Earthfile\\'" . earthfile-mode))
+(add-to-list 'auto-mode-alist '("\\.earth\\'" . earthfile-mode))
diff --git a/app-emacs/earthfile-mode/metadata.xml b/app-emacs/earthfile-mode/metadata.xml
new file mode 100644
index 000000000000..0c7339f08efc
--- /dev/null
+++ b/app-emacs/earthfile-mode/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <stabilize-allarches />
+ <upstream>
+ <bugs-to>https://github.com/earthly/earthly-emacs/issues/</bugs-to>
+ <remote-id type="github">earthly/earthly-emacs</remote-id>
+ </upstream>
+</pkgmetadata>