summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/ebib')
-rw-r--r--app-emacs/ebib/Manifest2
-rw-r--r--app-emacs/ebib/ebib-2.40.5.ebuild48
-rw-r--r--app-emacs/ebib/ebib-2.41.1.ebuild48
-rw-r--r--app-emacs/ebib/files/50ebib-gentoo.el5
-rw-r--r--app-emacs/ebib/metadata.xml19
5 files changed, 122 insertions, 0 deletions
diff --git a/app-emacs/ebib/Manifest b/app-emacs/ebib/Manifest
new file mode 100644
index 000000000000..0c048ad101f5
--- /dev/null
+++ b/app-emacs/ebib/Manifest
@@ -0,0 +1,2 @@
+DIST ebib-2.40.5.tar.gz 1048131 BLAKE2B 1a5639290eb6ce93b604e1e129c347e709f7c12a4db38516107e7ce2973fd4fb34e4dff0da16e7fff9395ca2168445e903848c50ca403447745dc4a405618c06 SHA512 9237368550f380e5dd40aa4f528cb9493e5b104e9c2264322128fd56e76b6167e6d1496ab8c663982b9b0dc4a65f5ca38bd7a5962e1281d27f9cc2d918805642
+DIST ebib-2.41.1.tar.gz 1048824 BLAKE2B 1746f782f3445e0d2bfb9cd9b62273b95afd4dc0e940943ba57f7e3b7855c4e1e174d9255d41a2829ad8f43bbbd04142da3c70a9afeb4ad467ecb7542215bcd9 SHA512 2b948b2381680779b68ab7015b1a840ac8437b63ae9a74a157d7b9beb37105eb1a12d170302e8000879233aaedb103006d4b31967f9b923d8879ff03c3f1c97b
diff --git a/app-emacs/ebib/ebib-2.40.5.ebuild b/app-emacs/ebib/ebib-2.40.5.ebuild
new file mode 100644
index 000000000000..b7bcc581be0e
--- /dev/null
+++ b/app-emacs/ebib/ebib-2.40.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+
+inherit elisp
+
+DESCRIPTION="BibTeX database manager for Emacs"
+HOMEPAGE="https://joostkremers.github.io/ebib/
+ https://github.com/joostkremers/ebib/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/joostkremers/${PN}.git"
+else
+ SRC_URI="https://github.com/joostkremers/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/compat-29.1.4.4
+ app-emacs/parsebib
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ app-emacs/with-simulated-input
+ )
+"
+
+DOCS=( README.md docs )
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests ert-runner test
+
+src_install() {
+ elisp_src_install
+
+ doinfo "${PN}.info"
+}
diff --git a/app-emacs/ebib/ebib-2.41.1.ebuild b/app-emacs/ebib/ebib-2.41.1.ebuild
new file mode 100644
index 000000000000..688763487ce1
--- /dev/null
+++ b/app-emacs/ebib/ebib-2.41.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+
+inherit elisp
+
+DESCRIPTION="BibTeX database manager for Emacs"
+HOMEPAGE="https://joostkremers.github.io/ebib/
+ https://github.com/joostkremers/ebib/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/joostkremers/${PN}.git"
+else
+ SRC_URI="https://github.com/joostkremers/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/compat-29.1.4.4
+ app-emacs/parsebib
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ app-emacs/with-simulated-input
+ )
+"
+
+DOCS=( README.md docs )
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests ert-runner test
+
+src_install() {
+ elisp_src_install
+
+ doinfo "${PN}.info"
+}
diff --git a/app-emacs/ebib/files/50ebib-gentoo.el b/app-emacs/ebib/files/50ebib-gentoo.el
new file mode 100644
index 000000000000..4345f7ef8470
--- /dev/null
+++ b/app-emacs/ebib/files/50ebib-gentoo.el
@@ -0,0 +1,5 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'ebib "ebib"
+ "Ebib, a BibTeX database manager." t)
+(autoload 'ebib-insert-citation "ebib"
+ "Insert a citation at POINT." t)
diff --git a/app-emacs/ebib/metadata.xml b/app-emacs/ebib/metadata.xml
new file mode 100644
index 000000000000..918804ccf762
--- /dev/null
+++ b/app-emacs/ebib/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/joostkremers/ebib/issues/</bugs-to>
+ <remote-id type="github">joostkremers/ebib</remote-id>
+ </upstream>
+ <longdescription>
+ Ebib is a BibTeX database manager that runs in GNU Emacs. With Ebib, you
+ can create and manage .bib-files, all within Emacs. It supports @string and
+ @preamble definitions, multi-line field values, searching, and integration
+ with Emacs' (La)TeX mode.
+ </longdescription>
+</pkgmetadata>