summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/edit-list')
-rw-r--r--app-emacs/edit-list/Manifest1
-rw-r--r--app-emacs/edit-list/edit-list-0.3.ebuild18
-rw-r--r--app-emacs/edit-list/files/50edit-list-gentoo.el3
-rw-r--r--app-emacs/edit-list/metadata.xml11
4 files changed, 33 insertions, 0 deletions
diff --git a/app-emacs/edit-list/Manifest b/app-emacs/edit-list/Manifest
new file mode 100644
index 000000000000..51da7b90bda9
--- /dev/null
+++ b/app-emacs/edit-list/Manifest
@@ -0,0 +1 @@
+DIST edit-list-0.3.el.bz2 2072 SHA256 2ce1542d60938987f835ed0fb67d975bf7ac0b1ce1b732ccdda07e65b427c23c SHA512 f7441d42e95b46d0cefd5cc32af5c0738aa15b338b81e31dc89fa968fc34e6387b6bc927999f4e077632acf6c2edcbbac609eb066363db896099f5fa3e19c1e7 WHIRLPOOL 8ec7b7c269cc6dd5c3cc74c2829420e7fea4e3155e003df8869499d9c3daf61a0f193ce443ffcbae4533f208aae0abd2dc306b5ee8e52d7d16429579e6a785c9
diff --git a/app-emacs/edit-list/edit-list-0.3.ebuild b/app-emacs/edit-list/edit-list-0.3.ebuild
new file mode 100644
index 000000000000..c77207080a2b
--- /dev/null
+++ b/app-emacs/edit-list/edit-list-0.3.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Edit a single list"
+HOMEPAGE="http://mwolson.org/projects/"
+# taken from http://mwolson.org/static/dist/elisp/edit-list.el
+SRC_URI="http://dev.gentoo.org/~ulm/distfiles/${P}.el.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/edit-list/files/50edit-list-gentoo.el b/app-emacs/edit-list/files/50edit-list-gentoo.el
new file mode 100644
index 000000000000..ec4d1975e3bc
--- /dev/null
+++ b/app-emacs/edit-list/files/50edit-list-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'edit-list "edit-list"
+ "Edit a list called LIST-NAME interactively." t)
diff --git a/app-emacs/edit-list/metadata.xml b/app-emacs/edit-list/metadata.xml
new file mode 100644
index 000000000000..4b4a912af00d
--- /dev/null
+++ b/app-emacs/edit-list/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<longdescription>
+ So you've just added an incorrect entry to auto-mode-alist and want to fix
+ it quickly. `M-x edit-list RET auto-mode-alist RET' to the rescue. Make your
+ changes and hit either `C-x C-s' or `C-c C-c' when done. Or just kill the
+ buffer if you change your mind.
+</longdescription>
+</pkgmetadata>