summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/editorconfig-emacs')
-rw-r--r--app-emacs/editorconfig-emacs/Manifest4
-rw-r--r--app-emacs/editorconfig-emacs/editorconfig-emacs-0.10.1.ebuild (renamed from app-emacs/editorconfig-emacs/editorconfig-emacs-0.8.2.ebuild)8
-rw-r--r--app-emacs/editorconfig-emacs/editorconfig-emacs-0.11.0.ebuild (renamed from app-emacs/editorconfig-emacs/editorconfig-emacs-0.7.8-r1.ebuild)22
-rw-r--r--app-emacs/editorconfig-emacs/files/50editorconfig-emacs-gentoo.el4
4 files changed, 25 insertions, 13 deletions
diff --git a/app-emacs/editorconfig-emacs/Manifest b/app-emacs/editorconfig-emacs/Manifest
index db6a5ee94481..10effe5cbd02 100644
--- a/app-emacs/editorconfig-emacs/Manifest
+++ b/app-emacs/editorconfig-emacs/Manifest
@@ -1,2 +1,2 @@
-DIST editorconfig-emacs-0.7.8.tar.gz 28250 BLAKE2B 8c09b7e495ff38d4276cdbaf60109f91b3e32215f2c6a8aceffd80a02cf024d79eac1739b3f2efa3697b78804da32d0cc2969db628d1064a0fb1db1b059a191d SHA512 21815a5a778ffef68b5205e409aa827c1bd6c9a8c542647ebec889a9f00f5b3f71e3a2072bc2f0373e8ce30c1bb57f5f6350953a3c149742a8e2e46ca9846c9a
-DIST editorconfig-emacs-0.8.2.tar.gz 39675 BLAKE2B a2a9641185a00c2908715b59a7e4429008f7587e00552ebc19f6cc38b6a10423c26a25557b887caaddc47d9c136fdec82476ef916e18c06b8228925b4554428b SHA512 6934418fd7890c49d8df7cdac1a0afe066e07ddf6274f674a4624dca47de278a78778f25beca793cdb537852beb7c8df5ea46743fb0bc753acccbb9974448e18
+DIST editorconfig-emacs-0.10.1.tar.gz 41259 BLAKE2B d03a86413122db05d87af4ea1a51087f22998d362e66965d0a6cd0f67ce57d7e6f15c403745ff018114715c1551f439b54a4c2e7e25325bd436c0959ea1a5595 SHA512 dc254ecf38b0f4b8850ff70f5a1a1ac72cd64e3795f5202d4bc8e13a0d1d9351e816e9a92f809cee6c6404348ba9bd1d908e17c2b0bce15dca112fe9cf1efc2b
+DIST editorconfig-emacs-0.11.0.tar.gz 41902 BLAKE2B 506ddec2dc5c68926a4255694cd3d4b3a97fcf6217774915f3eeb4a85f2665d7259a974e19b1059645b2057c65aecaf9fff5cb2827d8eb82e749cd1b0a7e8841 SHA512 61d96c093a4617488cd0e361bbe9c37b928b26b1e25b87a83e6f49ffeef0832110768a38ea274aa6f960e68b08839d3ace30ec185a94aa5ea478216c0a9f7585
diff --git a/app-emacs/editorconfig-emacs/editorconfig-emacs-0.8.2.ebuild b/app-emacs/editorconfig-emacs/editorconfig-emacs-0.10.1.ebuild
index 28b91eb6580a..ba6eb0bad920 100644
--- a/app-emacs/editorconfig-emacs/editorconfig-emacs-0.8.2.ebuild
+++ b/app-emacs/editorconfig-emacs/editorconfig-emacs-0.10.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -11,11 +11,11 @@ SRC_URI="https://github.com/editorconfig/${PN}/archive/v${PV}.tar.gz -> ${P}.tar
LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-RESTRICT="test" # make test requires a git repo
+KEYWORDS="amd64 ~arm64 x86"
+RESTRICT="test" # make test requires a git repo
SITEFILE="50${PN}-gentoo.el"
-DOCS="README.md"
+DOCS=( CHANGELOG.md README.md )
DOC_CONTENTS="The EditorConfig feature is not enabled as a site default.
Add the following line to your ~/.emacs file to activate it:
\n\t(editorconfig-mode 1)"
diff --git a/app-emacs/editorconfig-emacs/editorconfig-emacs-0.7.8-r1.ebuild b/app-emacs/editorconfig-emacs/editorconfig-emacs-0.11.0.ebuild
index 5108959d687f..70727ee7d63e 100644
--- a/app-emacs/editorconfig-emacs/editorconfig-emacs-0.7.8-r1.ebuild
+++ b/app-emacs/editorconfig-emacs/editorconfig-emacs-0.11.0.ebuild
@@ -1,21 +1,31 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit elisp readme.gentoo-r1
DESCRIPTION="EditorConfig plugin for emacs"
HOMEPAGE="https://github.com/editorconfig/editorconfig-emacs"
-SRC_URI="https://github.com/editorconfig/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/editorconfig/${PN}.git"
+else
+ SRC_URI="https://github.com/editorconfig/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS="amd64 x86"
-RESTRICT="test" # make test requires a git repo
SITEFILE="50${PN}-gentoo.el"
-DOCS="README.md"
+DOCS=( CHANGELOG.md README.md )
DOC_CONTENTS="The EditorConfig feature is not enabled as a site default.
Add the following line to your ~/.emacs file to activate it:
\n\t(editorconfig-mode 1)"
+
+elisp-enable-tests ert ./ert-tests -l ./ert-tests/editorconfig-core.el
diff --git a/app-emacs/editorconfig-emacs/files/50editorconfig-emacs-gentoo.el b/app-emacs/editorconfig-emacs/files/50editorconfig-emacs-gentoo.el
index 93d6816e8e7b..247365df8ecd 100644
--- a/app-emacs/editorconfig-emacs/files/50editorconfig-emacs-gentoo.el
+++ b/app-emacs/editorconfig-emacs/files/50editorconfig-emacs-gentoo.el
@@ -1,7 +1,9 @@
(add-to-list 'load-path "@SITELISP@")
+(autoload 'editorconfig-core-get-properties-hash "editorconfig-core"
+ "Get EditorConfig properties for FILE." t)
(autoload 'editorconfig-mode "editorconfig"
"Toggle EditorConfig feature." t)
(autoload 'editorconfig-conf-mode "editorconfig-conf-mode"
"Major mode for editing .editorconfig files." t)
(add-to-list 'auto-mode-alist
- '("/\\.editorconfig\\'" . editorconfig-conf-mode))
+ '("/\\.editorconfig\\'" . editorconfig-conf-mode))