summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/eimp/eimp-1.4.0.ebuild')
-rw-r--r--app-emacs/eimp/eimp-1.4.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-emacs/eimp/eimp-1.4.0.ebuild b/app-emacs/eimp/eimp-1.4.0.ebuild
new file mode 100644
index 000000000000..7699e258c546
--- /dev/null
+++ b/app-emacs/eimp/eimp-1.4.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs Image Manipulation Package"
+HOMEPAGE="https://github.com/nicferrier/eimp/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/nicferrier/${PN}.git"
+else
+ [[ ${PV} == 1.4.0 ]] && COMMIT=2e7536fe6d8f7faf1bad7a8ae37faba0162c3b4f
+ SRC_URI="https://github.com/nicferrier/${PN}/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${COMMIT}
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+SITEFILE="50${PN}-gentoo.el"