summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/emacs-el-fetch')
-rw-r--r--app-emacs/emacs-el-fetch/Manifest1
-rw-r--r--app-emacs/emacs-el-fetch/emacs-el-fetch-3.3.0.ebuild34
-rw-r--r--app-emacs/emacs-el-fetch/emacs-el-fetch-9999.ebuild34
-rw-r--r--app-emacs/emacs-el-fetch/metadata.xml18
4 files changed, 87 insertions, 0 deletions
diff --git a/app-emacs/emacs-el-fetch/Manifest b/app-emacs/emacs-el-fetch/Manifest
new file mode 100644
index 000000000000..7758ef58623c
--- /dev/null
+++ b/app-emacs/emacs-el-fetch/Manifest
@@ -0,0 +1 @@
+DIST emacs-el-fetch-3.3.0.tar.bz2 18166 BLAKE2B b55001eebc706954cf017cc56ed4d16a9f7309d36103d1bce94458ea8bdcb7a301201ff50f11d2f1b515ea63469ed8be00e4755dc8b1f9713158aa18a0788383 SHA512 7df309f4432b6490552654e4e68e1c01cf6c158a9759057421c879ce46b15a55092c3c17cd5d130c9de5425f6294ab5402c7684c2125c5f959e6a0973fcdcc64
diff --git a/app-emacs/emacs-el-fetch/emacs-el-fetch-3.3.0.ebuild b/app-emacs/emacs-el-fetch/emacs-el-fetch-3.3.0.ebuild
new file mode 100644
index 000000000000..bc142e225caa
--- /dev/null
+++ b/app-emacs/emacs-el-fetch/emacs-el-fetch-3.3.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Show system information in Neofetch-like style inside Emacs"
+HOMEPAGE="https://gitlab.com/xgqt/emacs-el-fetch/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/xgqt/${PN}.git"
+else
+ SRC_URI="https://gitlab.com/xgqt/${PN}/-/archive/${PV}/${P}.tar.bz2"
+ KEYWORDS="amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( app-emacs/buttercup )"
+
+src_compile() {
+ emake compile
+}
+
+src_install() {
+ einstalldocs
+ elisp-install ${PN} "${S}"/src/el-fetch/*.el{,c}
+ elisp-site-file-install "${S}"/extras/gentoo/50el-fetch-gentoo.el
+}
diff --git a/app-emacs/emacs-el-fetch/emacs-el-fetch-9999.ebuild b/app-emacs/emacs-el-fetch/emacs-el-fetch-9999.ebuild
new file mode 100644
index 000000000000..01ef92a64116
--- /dev/null
+++ b/app-emacs/emacs-el-fetch/emacs-el-fetch-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Show system information in Neofetch-like style inside Emacs"
+HOMEPAGE="https://gitlab.com/xgqt/emacs-el-fetch/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/xgqt/${PN}.git"
+else
+ SRC_URI="https://gitlab.com/xgqt/${PN}/-/archive/${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( app-emacs/buttercup )"
+
+src_compile() {
+ emake compile
+}
+
+src_install() {
+ einstalldocs
+ elisp-install ${PN} "${S}"/src/el-fetch/*.el{,c}
+ elisp-site-file-install "${S}"/extras/gentoo/50el-fetch-gentoo.el
+}
diff --git a/app-emacs/emacs-el-fetch/metadata.xml b/app-emacs/emacs-el-fetch/metadata.xml
new file mode 100644
index 000000000000..6bdc4f73ca31
--- /dev/null
+++ b/app-emacs/emacs-el-fetch/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <stabilize-allarches />
+ <upstream>
+ <maintainer status="active">
+ <email>xgqt@riseup.net</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <bugs-to>https://gitlab.com/xgqt/emacs-el-fetch/-/issues/</bugs-to>
+ <remote-id type="gitlab">xgqt/emacs-el-fetch</remote-id>
+ </upstream>
+</pkgmetadata>