summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/eselect-mode')
-rw-r--r--app-emacs/eselect-mode/Manifest4
-rw-r--r--app-emacs/eselect-mode/eselect-mode-1.4.26.ebuild (renamed from app-emacs/eselect-mode/eselect-mode-1.4.15.ebuild)13
-rw-r--r--app-emacs/eselect-mode/eselect-mode-1.4.27.ebuild (renamed from app-emacs/eselect-mode/eselect-mode-1.4.16.ebuild)13
-rw-r--r--app-emacs/eselect-mode/eselect-mode-9999.ebuild4
-rw-r--r--app-emacs/eselect-mode/metadata.xml2
5 files changed, 23 insertions, 13 deletions
diff --git a/app-emacs/eselect-mode/Manifest b/app-emacs/eselect-mode/Manifest
index e30198740b37..5cd4e19cf408 100644
--- a/app-emacs/eselect-mode/Manifest
+++ b/app-emacs/eselect-mode/Manifest
@@ -1,2 +1,2 @@
-DIST eselect-1.4.15.tar.xz 178996 BLAKE2B 4354d975c8af2e1de0f0c6efe2badc92584e947f9b73c05aac144caf8f9d74c850d366c7c225112322a504262b5f285f6e2e8d32223f1b2d4bac87db740a148c SHA512 ceb55fecc2bf70e816679af9b20653b29aa9ce24ca2d4cd0c6e02ab214689459bc2ccd5b3968ac49249b8fb6613c6055e7e76598b86c6a114a9abf847c4a2b58
-DIST eselect-1.4.16.tar.xz 178660 BLAKE2B dae97ee324cb67983c5395b5dc54c4b84d2da43f6a0c5c8ab81ff402ab211e9d1f1d3fe5c174b130ac1e11d3dd19e3812056274145415ee029e649cda880cd95 SHA512 264fb6122f5f7c9e73bb2250a94c3c0377e5263e2e5ae653ed58e08ebf6ed1b4aa165ae5c1d70b0156081c4db5672d1ec9d379782919d5b40a2f3e862378ce62
+DIST eselect-1.4.26.tar.xz 184332 BLAKE2B ee1e8890802fc50646c8d1d5219f1ab0ec5cfc0138c758f73ad6baccf673992bbf3e763d8e84491f33e724ba4e1cf3bed6971ba7fa4373e0f06464ff4a5fa1e6 SHA512 397ae2f15d90d722eb84225b08f1afaaf6f89758bfae5d93b0a1c3eddc997c21e74ab62e09ee5e71941d3a8587b3372b64336d12054c3bbf0e56e1ba398a26f9
+DIST eselect-1.4.27.tar.xz 184464 BLAKE2B 718874f4d0651194f361ca3202e5140982812bf486c8efe82354944d55206b0113fa135992203e8baa00019c3fd773a90ddaf67157c16f4ac2d69965d9822fbd SHA512 f534785fc1f79869840f420b4ab2b2bf35593c504cce878a6d3d07f75012cf32288009ea9ac2a5607dba216a794110a64c5f2c54d5d8a3c641328489cecc024b
diff --git a/app-emacs/eselect-mode/eselect-mode-1.4.15.ebuild b/app-emacs/eselect-mode/eselect-mode-1.4.26.ebuild
index faa2337419ab..1e9c5f558d6b 100644
--- a/app-emacs/eselect-mode/eselect-mode-1.4.15.ebuild
+++ b/app-emacs/eselect-mode/eselect-mode-1.4.26.ebuild
@@ -1,7 +1,12 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+# Packages sharing a common release tarball:
+# app-admin/eselect
+# app-emacs/eselect-mode
+# Please bump and mark them stable together!
inherit elisp
@@ -9,10 +14,10 @@ MY_P="eselect-${PV}"
DESCRIPTION="Emacs major mode for editing eselect files"
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Eselect"
SRC_URI="https://dev.gentoo.org/~ulm/eselect/${MY_P}.tar.xz"
+S="${WORKDIR}/${MY_P}/misc"
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-S="${WORKDIR}/${MY_P}/misc"
SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/eselect-mode/eselect-mode-1.4.16.ebuild b/app-emacs/eselect-mode/eselect-mode-1.4.27.ebuild
index faa2337419ab..ac6f27f42394 100644
--- a/app-emacs/eselect-mode/eselect-mode-1.4.16.ebuild
+++ b/app-emacs/eselect-mode/eselect-mode-1.4.27.ebuild
@@ -1,7 +1,12 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+# Packages sharing a common release tarball:
+# app-admin/eselect
+# app-emacs/eselect-mode
+# Please bump and mark them stable together!
inherit elisp
@@ -9,10 +14,10 @@ MY_P="eselect-${PV}"
DESCRIPTION="Emacs major mode for editing eselect files"
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Eselect"
SRC_URI="https://dev.gentoo.org/~ulm/eselect/${MY_P}.tar.xz"
+S="${WORKDIR}/${MY_P}/misc"
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-S="${WORKDIR}/${MY_P}/misc"
SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/eselect-mode/eselect-mode-9999.ebuild b/app-emacs/eselect-mode/eselect-mode-9999.ebuild
index 92002f841bae..0fe5c15bd545 100644
--- a/app-emacs/eselect-mode/eselect-mode-9999.ebuild
+++ b/app-emacs/eselect-mode/eselect-mode-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
MY_PN="eselect"
EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/eselect.git"
diff --git a/app-emacs/eselect-mode/metadata.xml b/app-emacs/eselect-mode/metadata.xml
index 173f63b7dd6a..086243897e26 100644
--- a/app-emacs/eselect-mode/metadata.xml
+++ b/app-emacs/eselect-mode/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>gnu-emacs@gentoo.org</email>