summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/ess/ess-17.11.ebuild')
-rw-r--r--app-emacs/ess/ess-17.11.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-emacs/ess/ess-17.11.ebuild b/app-emacs/ess/ess-17.11.ebuild
new file mode 100644
index 000000000000..30a7a1782eb8
--- /dev/null
+++ b/app-emacs/ess/ess-17.11.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit elisp readme.gentoo-r1
+
+DESCRIPTION="Emacs Speaks Statistics"
+HOMEPAGE="http://ess.r-project.org/"
+# ${P}.tgz is plain (uncompresses) tar, so use zip for this version
+SRC_URI="http://ess.r-project.org/downloads/ess/${P}.zip"
+
+LICENSE="GPL-2+ GPL-3+ Texinfo-manual"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+
+DEPEND="app-text/texi2html
+ virtual/latex-base
+ app-arch/unzip"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ default
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" \
+ INFODIR="${ED}/usr/share/info" \
+ LISPDIR="${ED}${SITELISP}/ess" \
+ DOCDIR="${ED}/usr/share/doc/${PF}" \
+ install
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ # Most documentation is installed by the package's build system.
+ rm -f "${ED}${SITELISP}/${PN}/ChangeLog"
+ dodoc ChangeLog *NEWS doc/{TODO,ess-intro.pdf}
+ newdoc doc/ChangeLog ChangeLog-doc
+ newdoc lisp/ChangeLog ChangeLog-lisp
+
+ DOC_CONTENTS="Please see /usr/share/doc/${PF} for the complete
+ documentation. Usage hints are in ${SITELISP}/${PN}/ess-site.el ."
+ readme.gentoo_create_doc
+}