summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/git-timemachine/git-timemachine-9999.ebuild')
-rw-r--r--app-emacs/git-timemachine/git-timemachine-9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-emacs/git-timemachine/git-timemachine-9999.ebuild b/app-emacs/git-timemachine/git-timemachine-9999.ebuild
new file mode 100644
index 000000000000..34600dc73e46
--- /dev/null
+++ b/app-emacs/git-timemachine/git-timemachine-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Step through historic versions of git controlled files in GNU Emacs"
+HOMEPAGE="https://codeberg.org/pidu/git-timemachine/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://codeberg.org/pidu/${PN}.git"
+else
+ SRC_URI="https://codeberg.org/pidu/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"