summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/go-mode')
-rw-r--r--app-emacs/go-mode/Manifest1
-rw-r--r--app-emacs/go-mode/files/50go-mode-gentoo.el2
-rw-r--r--app-emacs/go-mode/go-mode-1.5.0.ebuild18
-rw-r--r--app-emacs/go-mode/go-mode-1.6.0.ebuild21
4 files changed, 7 insertions, 35 deletions
diff --git a/app-emacs/go-mode/Manifest b/app-emacs/go-mode/Manifest
index 882da91fac0a..95791ec2bfba 100644
--- a/app-emacs/go-mode/Manifest
+++ b/app-emacs/go-mode/Manifest
@@ -1,2 +1 @@
-DIST go-mode-1.5.0.tar.gz 36876 BLAKE2B dca184f1cb79c919067ffecd1111f2404685459dca374a1ff14512067d0235bc862a04cb5fb014620856d0d03c15668149d0c62c238098b8561ea2512b26ec36 SHA512 fee67461467feb272dbb90abbad3df786f984925747ad8588c271784f8d27db888dd1da9d4589fb63ccfded1a833b01bb860d3254b00ca5e3f3aa89f199880c3
DIST go-mode-1.6.0.tar.xz 40764 BLAKE2B e88be130809da4d00978698c6f2cdd0d844a6c6646c23152fcb5f4c3a9a1596ca8d79199d811f8e7d64f6c245cd7bb80b9a403fc0e1362e6b2c556466b45e80d SHA512 24594b1de8ae45922a6a7c7cee8097f4a8ebdac477ae086595a73c5a7757b8c2f8c0249ad4ccf313ca13332790d76495b7c212d2e0e721f98753f23b2d6511c1
diff --git a/app-emacs/go-mode/files/50go-mode-gentoo.el b/app-emacs/go-mode/files/50go-mode-gentoo.el
deleted file mode 100644
index 331db4c92fef..000000000000
--- a/app-emacs/go-mode/files/50go-mode-gentoo.el
+++ /dev/null
@@ -1,2 +0,0 @@
-(add-to-list 'load-path "@SITELISP@")
-(load "go-mode-autoloads" nil t)
diff --git a/app-emacs/go-mode/go-mode-1.5.0.ebuild b/app-emacs/go-mode/go-mode-1.5.0.ebuild
deleted file mode 100644
index 67936074eb88..000000000000
--- a/app-emacs/go-mode/go-mode-1.5.0.ebuild
+++ /dev/null
@@ -1,18 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit elisp
-
-DESCRIPTION="An improved Go mode for emacs"
-HOMEPAGE="https://github.com/dominikh/go-mode.el"
-SRC_URI="https://github.com/dominikh/go-mode.el/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-
-S="${WORKDIR}/go-mode.el-${PV}"
-SITEFILE="50${PN}-gentoo.el"
-DOCS="AUTHORS README.md"
diff --git a/app-emacs/go-mode/go-mode-1.6.0.ebuild b/app-emacs/go-mode/go-mode-1.6.0.ebuild
index 76def2ac8579..df816afc4593 100644
--- a/app-emacs/go-mode/go-mode-1.6.0.ebuild
+++ b/app-emacs/go-mode/go-mode-1.6.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -17,13 +17,17 @@ SRC_URI="https://dev.gentoo.org/~matthew/distfiles/${P}.tar.xz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~arm64"
+
+ELISP_REMOVE="test/go-fill-paragraph-test.el"
SITEFILE="50${PN}-1.6.0-gentoo.el"
DOCS=( README.md )
+elisp-enable-tests ert test
+
src_prepare() {
- default
+ elisp_src_prepare
# fix path to testdata directory when running tests
sed -i 's|testdata|test/&|g' \
@@ -34,14 +38,3 @@ src_compile() {
elisp_src_compile
elisp-make-autoload-file
}
-
-src_test() {
- for suite in test/*-test.el; do
- ${EMACS} ${EMACSFLAGS} \
- -L . \
- -l ert \
- -l go-mode \
- -l "${suite}" \
- -f ert-run-tests-batch-and-exit || die "test ${suite} failed"
- done
-}