summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/ht/ht-2.3.ebuild')
-rw-r--r--app-emacs/ht/ht-2.3.ebuild29
1 files changed, 18 insertions, 11 deletions
diff --git a/app-emacs/ht/ht-2.3.ebuild b/app-emacs/ht/ht-2.3.ebuild
index 2b56bec9cad3..57af14755328 100644
--- a/app-emacs/ht/ht-2.3.ebuild
+++ b/app-emacs/ht/ht-2.3.ebuild
@@ -1,28 +1,35 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit elisp
-IUSE=""
-
DESCRIPTION="The missing hash table library for Emacs"
HOMEPAGE="https://github.com/Wilfred/ht.el"
SRC_URI="https://github.com/Wilfred/ht.el/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/ht.el-${PV}"
+
LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS="~amd64"
-DOCS="CHANGELOG.md README.md"
-
-SITEFILE="50${PN}-gentoo.el"
+KEYWORDS="amd64 ~arm64"
+IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="
>=app-emacs/dash-2.12.0
"
-DEPEND=${RDEPEND}
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ app-emacs/f
+ app-emacs/ert-runner
+ )
+"
-S="${WORKDIR}/ht.el-${PV}"
+DOCS="CHANGELOG.md README.md"
+SITEFILE="50${PN}-gentoo.el"
-# Requires unpackaged dependencies, e.g. Cask
-RESTRICT="test"
+src_test() {
+ ert-runner --reporter ert+duration --script || die
+}