summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/markdown-mode/markdown-mode-2.1.ebuild')
-rw-r--r--app-emacs/markdown-mode/markdown-mode-2.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-emacs/markdown-mode/markdown-mode-2.1.ebuild b/app-emacs/markdown-mode/markdown-mode-2.1.ebuild
new file mode 100644
index 000000000000..2770855453bd
--- /dev/null
+++ b/app-emacs/markdown-mode/markdown-mode-2.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Major mode for editing Markdown-formatted text files"
+HOMEPAGE="http://jblevins.org/projects/markdown-mode/"
+# Cannot use this url because its hash differ about every five minutes
+# SRC_URI="http://jblevins.org/git/${PN}.git/snapshot/${P}.tar.gz"
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.el.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="|| ( dev-python/markdown2 dev-python/markdown )"
+
+SITEFILE="50${PN}-gentoo.el"
+
+ELISP_PATCHES=( ${P}-text-auto-mode.patch )