summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/mmm-mode')
-rw-r--r--app-emacs/mmm-mode/Manifest3
-rw-r--r--app-emacs/mmm-mode/files/mmm-mode-0.5.7-texinfo-encoding.patch11
-rw-r--r--app-emacs/mmm-mode/mmm-mode-0.5.10.ebuild30
-rw-r--r--app-emacs/mmm-mode/mmm-mode-0.5.11.ebuild30
-rw-r--r--app-emacs/mmm-mode/mmm-mode-0.5.7.ebuild21
5 files changed, 62 insertions, 33 deletions
diff --git a/app-emacs/mmm-mode/Manifest b/app-emacs/mmm-mode/Manifest
index 504498bd342e..2dedb08ec6d9 100644
--- a/app-emacs/mmm-mode/Manifest
+++ b/app-emacs/mmm-mode/Manifest
@@ -1 +1,2 @@
-DIST mmm-mode-0.5.7.tar.gz 176034 BLAKE2B 23fed0f260c9f46134d83d29e96b96ff331aa0fbe8d121663b74de944489d1a51948f6fba729129e47a34e1ef48cfb0f8bbc45f6ab8f548001bbe0e88a61aeca SHA512 3afb77b3351c8ea5844cd57bb873e6ebe91ce1e268d0d585581482f5039c64ea80fc7aa620e45330eca0eb7839223764164ccc09e932b54f23f3f37c9953cb39
+DIST mmm-mode-0.5.10.tar.gz 110491 BLAKE2B ea60a2ac871fbacbb358809f682ee174612401ee9e5bafb7f322891710ebcc833e7efeae1c3284e8a30fb95c3aac7c86ccad758b4d65bb9aee772ecc5c9a013d SHA512 c1caffe75d97950850a2c6d53554b17d63eba1a9ee653e469046dfd131ad840e8b9fa5114f6bf7967e3a4797fc7db0eab484d48017f1df6e043f935960b9d1df
+DIST mmm-mode-0.5.11.tar.gz 110809 BLAKE2B 4fd3cb383dc15fb78b47e8da5ec484783421d3101755a3967b2348ecb073cee9476de1597e75a48beb275e9ec25556dc43330337b5a69fe8b2aa986795fa8918 SHA512 077e0dc8846c411033713307d1db5fc7fdf0b25a283995f27c4cbf210fc972923cc9542ef24c10539d11fa0faf91cca6f397ac7ff701a305516105c86660da8e
diff --git a/app-emacs/mmm-mode/files/mmm-mode-0.5.7-texinfo-encoding.patch b/app-emacs/mmm-mode/files/mmm-mode-0.5.7-texinfo-encoding.patch
deleted file mode 100644
index f83d24dae131..000000000000
--- a/app-emacs/mmm-mode/files/mmm-mode-0.5.7-texinfo-encoding.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-https://bugs.gentoo.org/695954
-
---- a/mmm.texinfo
-+++ b/mmm.texinfo
-@@ -1,5 +1,6 @@
- \input texinfo
- @c %**start of header
-+@documentencoding ISO-8859-1
- @setfilename mmm.info
- @settitle MMM Mode Manual
- @c %**end of header
diff --git a/app-emacs/mmm-mode/mmm-mode-0.5.10.ebuild b/app-emacs/mmm-mode/mmm-mode-0.5.10.ebuild
new file mode 100644
index 000000000000..ff1f2a71aad5
--- /dev/null
+++ b/app-emacs/mmm-mode/mmm-mode-0.5.10.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Enables the user to edit different parts of a file in different major modes"
+HOMEPAGE="http://mmm-mode.sourceforge.net/
+ https://github.com/dgutov/mmm-mode/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/dgutov/${PN}.git"
+else
+ SRC_URI="https://github.com/dgutov/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+fi
+
+LICENSE="GPL-2+ Texinfo-manual"
+SLOT="0"
+
+BDEPEND="sys-apps/texinfo"
+
+DOCS=( AUTHORS FAQ NEWS README README.Mason TODO )
+ELISP_TEXINFO="mmm.texi"
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/mmm-mode/mmm-mode-0.5.11.ebuild b/app-emacs/mmm-mode/mmm-mode-0.5.11.ebuild
new file mode 100644
index 000000000000..0da9641d4ed6
--- /dev/null
+++ b/app-emacs/mmm-mode/mmm-mode-0.5.11.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Enables the user to edit different parts of a file in different major modes"
+HOMEPAGE="http://mmm-mode.sourceforge.net/
+ https://github.com/dgutov/mmm-mode/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/dgutov/${PN}.git"
+else
+ SRC_URI="https://github.com/dgutov/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+fi
+
+LICENSE="GPL-2+ Texinfo-manual"
+SLOT="0"
+
+BDEPEND="sys-apps/texinfo"
+
+DOCS=( AUTHORS FAQ NEWS README README.Mason TODO )
+ELISP_TEXINFO="mmm.texi"
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/mmm-mode/mmm-mode-0.5.7.ebuild b/app-emacs/mmm-mode/mmm-mode-0.5.7.ebuild
deleted file mode 100644
index b9a5768acc63..000000000000
--- a/app-emacs/mmm-mode/mmm-mode-0.5.7.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit elisp
-
-DESCRIPTION="Enables the user to edit different parts of a file in different major modes"
-HOMEPAGE="http://mmm-mode.sourceforge.net/"
-SRC_URI="https://github.com/purcell/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2+ Texinfo-manual"
-SLOT="0"
-KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-
-BDEPEND="sys-apps/texinfo"
-
-PATCHES=("${FILESDIR}"/${P}-texinfo-encoding.patch)
-SITEFILE="50${PN}-gentoo.el"
-ELISP_TEXINFO="mmm.texinfo"
-DOCS="AUTHORS FAQ NEWS README README.Mason TODO"