summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/muse/muse-3.20-r2.ebuild')
-rw-r--r--app-emacs/muse/muse-3.20-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-emacs/muse/muse-3.20-r2.ebuild b/app-emacs/muse/muse-3.20-r2.ebuild
new file mode 100644
index 000000000000..06bdc75d2f6f
--- /dev/null
+++ b/app-emacs/muse/muse-3.20-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="An authoring and publishing environment for Emacs"
+HOMEPAGE="https://www.gnu.org/software/emacs-muse/"
+SRC_URI="https://github.com/alexott/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+ FDL-1.2+ GPL-2 MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+#IUSE="test"
+RESTRICT="test" #426546
+
+#DEPEND="test? ( app-emacs/htmlize )"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ elisp-install "${PN}" lisp/*.el lisp/*.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ doinfo texi/muse.info
+ dodoc AUTHORS NEWS README ChangeLog*
+ dodoc -r contrib etc examples experimental scripts
+}