summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/nxml-docbook5-schemas')
-rw-r--r--app-emacs/nxml-docbook5-schemas/Manifest1
-rw-r--r--app-emacs/nxml-docbook5-schemas/nxml-docbook5-schemas-5.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-emacs/nxml-docbook5-schemas/Manifest b/app-emacs/nxml-docbook5-schemas/Manifest
index c8eb049bed19..1a93ea1bf37c 100644
--- a/app-emacs/nxml-docbook5-schemas/Manifest
+++ b/app-emacs/nxml-docbook5-schemas/Manifest
@@ -1 +1,2 @@
DIST docbookxi-5.0.rnc 292523 BLAKE2B 13ae2f3756485845e2fc6dca87bce5eb12c419c84b6edaab5051b075700387c32904f54286756c5fed2480c17af00e385845105a94b13ced9fe13ba959e22224 SHA512 13309beb2dbf76168889a962782d3dd1849fb254ebf1941ffd4fcfc272353ba0ddece509a9b74250462b3e1eff12f31fc408aa790e0efea01d527482b3fa3a48
+DIST docbookxi-5.1.rnc 361312 BLAKE2B 374c622718b0c9969561a76874fe878570af4fd2a1288f79c8b51c1474ac75e7e98cddd2be7bedadf8271aefccd770cf70ac4499d45187b327c0a50e402b1a48 SHA512 28191653224a301a3ce7541ca1fcc5d526b76fcce00533adbdc16507ddaa768efedebe31b0fade6b8ea7b28d3d33e9656363dfc667eab227280bf6061673a31c
diff --git a/app-emacs/nxml-docbook5-schemas/nxml-docbook5-schemas-5.1.ebuild b/app-emacs/nxml-docbook5-schemas/nxml-docbook5-schemas-5.1.ebuild
new file mode 100644
index 000000000000..3cede296fe4d
--- /dev/null
+++ b/app-emacs/nxml-docbook5-schemas/nxml-docbook5-schemas-5.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+DESCRIPTION="Add support for DocBook 5 schemas to NXML"
+HOMEPAGE="https://docbook.org/schemas/5x.html"
+SRC_URI="https://docbook.org/xml/${PV}/rng/docbookxi.rnc -> docbookxi-${PV}.rnc"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}"
+SITEFILE="60${PN}-gentoo.el"
+
+src_unpack() { :; }
+
+src_compile() { :; }
+
+src_install() {
+ insinto ${SITEETC}/${PN}
+ doins "${FILESDIR}"/schemas.xml
+ newins "${DISTDIR}"/docbookxi-${PV}.rnc docbookxi.rnc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}