summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/org-modern')
-rw-r--r--app-emacs/org-modern/Manifest2
-rw-r--r--app-emacs/org-modern/files/50org-modern-gentoo.el7
-rw-r--r--app-emacs/org-modern/metadata.xml20
-rw-r--r--app-emacs/org-modern/org-modern-1.1.ebuild23
-rw-r--r--app-emacs/org-modern/org-modern-1.2.ebuild23
5 files changed, 75 insertions, 0 deletions
diff --git a/app-emacs/org-modern/Manifest b/app-emacs/org-modern/Manifest
new file mode 100644
index 000000000000..416c95fe81b1
--- /dev/null
+++ b/app-emacs/org-modern/Manifest
@@ -0,0 +1,2 @@
+DIST org-modern-1.1.tar.gz 24267 BLAKE2B a556e58384b5cbb24f768778bd0e3f820b63fba0d63590d8943054e4bf2a6ae1137c145bf72282659a22ec4236de036105b82f5a288687dadf6463744c321f3a SHA512 722a9c30031400e060aa4af78fe16ddda362e7803927c8b2ab379ee43a0711cc35fb5c21c617389a1b3ecdfa8123ab6b200d5825e80cecf9b017488a24b376ed
+DIST org-modern-1.2.tar.gz 24466 BLAKE2B f7a0426e203078d048744532efc582a2ebf2ed66fd2ff88ea1f7696d442ced5ce00b124c0b57d1dc6a1f79aa5c1f732f4fb7399642cb2957878cc9fa8be903be SHA512 1d5f4bee037aa44433de33701c87273332cd351f9f52cb787f799de084421481cdf95785761c33caed0660a2c9ff6f00617b93be1b6f39a1e1ab70af8a64fd35
diff --git a/app-emacs/org-modern/files/50org-modern-gentoo.el b/app-emacs/org-modern/files/50org-modern-gentoo.el
new file mode 100644
index 000000000000..a10b355780f8
--- /dev/null
+++ b/app-emacs/org-modern/files/50org-modern-gentoo.el
@@ -0,0 +1,7 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'global-org-modern-mode "org-modern"
+ "Global org-modern-mode." t)
+(autoload 'org-modern-agenda "org-modern"
+ "Finalize Org agenda highlighting." t)
+(autoload 'org-modern-mode "org-modern"
+ "Modern looks for Org." t)
diff --git a/app-emacs/org-modern/metadata.xml b/app-emacs/org-modern/metadata.xml
new file mode 100644
index 000000000000..68e44f1c601a
--- /dev/null
+++ b/app-emacs/org-modern/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ This package implements a “modern” style for your Org buffers using font
+ locking and text properties. The package styles headlines, keywords, tables
+ and source blocks. The styling is configurable, you can enable, disable or
+ modify the style of each syntax element individually via the org-modern
+ customization group.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/minad/org-modern/issues/</bugs-to>
+ <remote-id type="github">minad/org-modern</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/org-modern/org-modern-1.1.ebuild b/app-emacs/org-modern/org-modern-1.1.ebuild
new file mode 100644
index 000000000000..9fa99148a3ca
--- /dev/null
+++ b/app-emacs/org-modern/org-modern-1.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Modern style for your GNU Emacs Org buffers"
+HOMEPAGE="https://github.com/minad/org-modern/"
+SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=app-emacs/compat-29.1.4.0"
+BDEPEND="${RDEPEND}"
+
+DOCS=( README.org example.org )
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/org-modern/org-modern-1.2.ebuild b/app-emacs/org-modern/org-modern-1.2.ebuild
new file mode 100644
index 000000000000..9fa99148a3ca
--- /dev/null
+++ b/app-emacs/org-modern/org-modern-1.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Modern style for your GNU Emacs Org buffers"
+HOMEPAGE="https://github.com/minad/org-modern/"
+SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=app-emacs/compat-29.1.4.0"
+BDEPEND="${RDEPEND}"
+
+DOCS=( README.org example.org )
+SITEFILE="50${PN}-gentoo.el"