summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/org-roam')
-rw-r--r--app-emacs/org-roam/Manifest1
-rw-r--r--app-emacs/org-roam/files/50org-roam-gentoo.el3
-rw-r--r--app-emacs/org-roam/metadata.xml15
-rw-r--r--app-emacs/org-roam/org-roam-2.2.2-r1.ebuild41
-rw-r--r--app-emacs/org-roam/org-roam-2.2.2-r2.ebuild46
-rw-r--r--app-emacs/org-roam/org-roam-9999.ebuild46
6 files changed, 152 insertions, 0 deletions
diff --git a/app-emacs/org-roam/Manifest b/app-emacs/org-roam/Manifest
new file mode 100644
index 000000000000..ded5031c0590
--- /dev/null
+++ b/app-emacs/org-roam/Manifest
@@ -0,0 +1 @@
+DIST org-roam-2.2.2.tar.gz 37466184 BLAKE2B f929d765493a640f5df0417dfd37618049d7af24ac78fd1dc00ef79bc7576ca856d6cc926a30bcd0f69c27595bf1ce517e49fe9e592dd208f08b83d03544d80a SHA512 737baff1b3ab7a3008ed3bf1816f8cf1ce461dccfe8e195e8ac11ba50c2c983573d62c364c75a119facf3131f90764842bfe121cdad0a4c2add606aa806aef10
diff --git a/app-emacs/org-roam/files/50org-roam-gentoo.el b/app-emacs/org-roam/files/50org-roam-gentoo.el
new file mode 100644
index 000000000000..ac1c52bf5855
--- /dev/null
+++ b/app-emacs/org-roam/files/50org-roam-gentoo.el
@@ -0,0 +1,3 @@
+;;; app-emacs/org-roam site configuration -*- lexical-binding: t; -*-
+(add-to-list 'load-path "@SITELISP@")
+(load "@SITELISP@/org-roam-autoloads.el" nil t)
diff --git a/app-emacs/org-roam/metadata.xml b/app-emacs/org-roam/metadata.xml
new file mode 100644
index 000000000000..a88691fba13b
--- /dev/null
+++ b/app-emacs/org-roam/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arsen@gentoo.org</email>
+ <description>Arsen Arsenović</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">org-roam/org-roam</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/org-roam/org-roam-2.2.2-r1.ebuild b/app-emacs/org-roam/org-roam-2.2.2-r1.ebuild
new file mode 100644
index 000000000000..d4214ed1928c
--- /dev/null
+++ b/app-emacs/org-roam/org-roam-2.2.2-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+inherit elisp
+
+DESCRIPTION="Rudimentary Roam replica with Org-mode"
+HOMEPAGE="https://github.com/org-roam/org-roam"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+else
+ SRC_URI="
+ https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ "
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ app-emacs/dash
+ app-emacs/magit
+ app-emacs/emacsql[sqlite]
+"
+BDEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests buttercup tests
+
+src_install() {
+ elisp-make-autoload-file
+ elisp_src_install
+}
diff --git a/app-emacs/org-roam/org-roam-2.2.2-r2.ebuild b/app-emacs/org-roam/org-roam-2.2.2-r2.ebuild
new file mode 100644
index 000000000000..8432aafaa462
--- /dev/null
+++ b/app-emacs/org-roam/org-roam-2.2.2-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+inherit elisp
+
+DESCRIPTION="Rudimentary Roam replica with Org-mode"
+HOMEPAGE="https://github.com/org-roam/org-roam"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+else
+ SRC_URI="
+ https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ "
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ app-emacs/dash
+ app-emacs/magit
+ app-emacs/emacsql[sqlite]
+"
+BDEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests buttercup tests
+
+src_prepare() {
+ default
+ mv extensions/*.el . || die
+}
+
+src_install() {
+ elisp-make-autoload-file
+ elisp_src_install
+}
diff --git a/app-emacs/org-roam/org-roam-9999.ebuild b/app-emacs/org-roam/org-roam-9999.ebuild
new file mode 100644
index 000000000000..8432aafaa462
--- /dev/null
+++ b/app-emacs/org-roam/org-roam-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+inherit elisp
+
+DESCRIPTION="Rudimentary Roam replica with Org-mode"
+HOMEPAGE="https://github.com/org-roam/org-roam"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+else
+ SRC_URI="
+ https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ "
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ app-emacs/dash
+ app-emacs/magit
+ app-emacs/emacsql[sqlite]
+"
+BDEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests buttercup tests
+
+src_prepare() {
+ default
+ mv extensions/*.el . || die
+}
+
+src_install() {
+ elisp-make-autoload-file
+ elisp_src_install
+}