summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/parseclj/parseclj-1.1.1.ebuild')
-rw-r--r--app-emacs/parseclj/parseclj-1.1.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-emacs/parseclj/parseclj-1.1.1.ebuild b/app-emacs/parseclj/parseclj-1.1.1.ebuild
new file mode 100644
index 000000000000..e65c3074b14f
--- /dev/null
+++ b/app-emacs/parseclj/parseclj-1.1.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Clojure Parser for Emacs Lisp"
+HOMEPAGE="https://github.com/clojure-emacs/parseclj/"
+SRC_URI="https://github.com/clojure-emacs/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( app-emacs/ert-runner )"
+
+DOCS=( CHANGELOG.md DESIGN.md README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ert-runner -L . -L test --reporter ert+duration --script test || die
+}