summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/php-mode')
-rw-r--r--app-emacs/php-mode/Manifest3
-rw-r--r--app-emacs/php-mode/metadata.xml3
-rw-r--r--app-emacs/php-mode/php-mode-1.23.0.ebuild18
-rw-r--r--app-emacs/php-mode/php-mode-1.24.0.ebuild19
-rw-r--r--app-emacs/php-mode/php-mode-1.25.1.ebuild34
-rw-r--r--app-emacs/php-mode/php-mode-9999.ebuild34
6 files changed, 71 insertions, 40 deletions
diff --git a/app-emacs/php-mode/Manifest b/app-emacs/php-mode/Manifest
index 739d759c161b..9668562fe164 100644
--- a/app-emacs/php-mode/Manifest
+++ b/app-emacs/php-mode/Manifest
@@ -1,2 +1 @@
-DIST php-mode-1.23.0.tar.gz 94451 BLAKE2B 324eda995ba8d93ca9bec691c88b05caac3d6786b2d1caac39dc34f513e8a026b3803ad3712729b147a8ee839fe337bf11ebaa1b718cb4c741997a9e1c9279a3 SHA512 051adf317ac1dc4ae14b3aaad9aa15ef650a74c7c1ff134ff9a26664cc7494b522957d9cbed981ec398e9bdc6ccae4437c628b2fe3535e8f2a95da34363ec88a
-DIST php-mode-1.24.0.tar.gz 94715 BLAKE2B 226dfe72153f541d8a7ee396dc3cb49c2b0a26c084a3ea36f812f4e923cf364d3ddca0192b87b5a068a9a19a9cfa1227a91f0793374e513b957764b0c867df3f SHA512 fd26f1f022d20bf3dffb772f3735b244cf7e2b4fe51ed35c6ead4f7a7b21686cecd2db54f882a6622a34e3265b4af68d71b589d5adc79b15be3c5e4019ea026a
+DIST php-mode-1.25.1.tar.gz 131105 BLAKE2B 9672d3e71ead28cc7db78ca5c148340b1e1e2552804c172ac14003384c72c3eccf56f5c258da8f0b6e218976100a374af8f2f0c68595ee6b4a2a90d965b60644 SHA512 4e1acf92a95b7e836893160ae3a3bd7a510d7fa0af5f7a6eb3cc8141c6a90b803a339b5d49527ace4f6ec06364ca794f4b834b7391617420a3219dc95fbf61cc
diff --git a/app-emacs/php-mode/metadata.xml b/app-emacs/php-mode/metadata.xml
index ff7307665377..60878cd590df 100644
--- a/app-emacs/php-mode/metadata.xml
+++ b/app-emacs/php-mode/metadata.xml
@@ -7,6 +7,7 @@
</maintainer>
<stabilize-allarches/>
<upstream>
- <remote-id type="sourceforge">php-mode</remote-id>
+ <bugs-to>https://github.com/emacs-php/php-mode/issues/</bugs-to>
+ <remote-id type="github">emacs-php/php-mode</remote-id>
</upstream>
</pkgmetadata>
diff --git a/app-emacs/php-mode/php-mode-1.23.0.ebuild b/app-emacs/php-mode/php-mode-1.23.0.ebuild
deleted file mode 100644
index 2924a48fb04d..000000000000
--- a/app-emacs/php-mode/php-mode-1.23.0.ebuild
+++ /dev/null
@@ -1,18 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-NEED_EMACS=24
-
-inherit elisp
-
-DESCRIPTION="GNU Emacs major mode for editing PHP code"
-HOMEPAGE="https://github.com/ejmr/php-mode"
-SRC_URI="https://github.com/ejmr/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
-
-SITEFILE="50${PN}-gentoo.el"
-DOCS="README*.md CHANGELOG.md CONTRIBUTING.md"
diff --git a/app-emacs/php-mode/php-mode-1.24.0.ebuild b/app-emacs/php-mode/php-mode-1.24.0.ebuild
deleted file mode 100644
index 306053b9e61f..000000000000
--- a/app-emacs/php-mode/php-mode-1.24.0.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-NEED_EMACS=24
-
-inherit elisp
-
-DESCRIPTION="GNU Emacs major mode for editing PHP code"
-HOMEPAGE="https://github.com/ejmr/php-mode"
-SRC_URI="https://github.com/ejmr/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${P}/lisp"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
-
-SITEFILE="50${PN}-gentoo.el"
-DOCS="../README*.md ../AUTHORS.md ../CHANGELOG.md ../CONTRIBUTING.md"
diff --git a/app-emacs/php-mode/php-mode-1.25.1.ebuild b/app-emacs/php-mode/php-mode-1.25.1.ebuild
new file mode 100644
index 000000000000..8b2fd8c1e115
--- /dev/null
+++ b/app-emacs/php-mode/php-mode-1.25.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="GNU Emacs major mode for editing PHP code"
+HOMEPAGE="https://github.com/emacs-php/php-mode/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emacs-php/${PN}.git"
+else
+ SRC_URI="https://github.com/emacs-php/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
+fi
+
+S="${WORKDIR}"/${P}/lisp
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( ../AUTHORS.md ../CHANGELOG.md ../CONTRIBUTING.md ../README{,.ja}.md ../docs )
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests ert "${S}" -L ../tests -l ../tests/php-mode-test.el
+
+src_test() {
+ touch ../tests/project/1/.git || die
+
+ elisp_src_test
+}
diff --git a/app-emacs/php-mode/php-mode-9999.ebuild b/app-emacs/php-mode/php-mode-9999.ebuild
new file mode 100644
index 000000000000..a4c5626eb7ec
--- /dev/null
+++ b/app-emacs/php-mode/php-mode-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="GNU Emacs major mode for editing PHP code"
+HOMEPAGE="https://github.com/emacs-php/php-mode/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emacs-php/${PN}.git"
+else
+ SRC_URI="https://github.com/emacs-php/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+fi
+
+S="${WORKDIR}"/${P}/lisp
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( ../AUTHORS.md ../CHANGELOG.md ../CONTRIBUTING.md ../README{,.ja}.md ../docs )
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests ert "${S}" -L ../tests -l ../tests/php-mode-test.el
+
+src_test() {
+ touch ../tests/project/1/.git || die
+
+ elisp_src_test
+}