summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/poke')
-rw-r--r--app-emacs/poke/Manifest2
-rw-r--r--app-emacs/poke/files/50poke-el-gentoo.el5
-rw-r--r--app-emacs/poke/metadata.xml16
-rw-r--r--app-emacs/poke/poke-3.0.ebuild27
-rw-r--r--app-emacs/poke/poke-3.2.ebuild28
5 files changed, 78 insertions, 0 deletions
diff --git a/app-emacs/poke/Manifest b/app-emacs/poke/Manifest
new file mode 100644
index 000000000000..92caa56d2c63
--- /dev/null
+++ b/app-emacs/poke/Manifest
@@ -0,0 +1,2 @@
+DIST poke-3.0-el.tar.gz 17015 BLAKE2B 27dc499b128231ed2ce39018fc872c60ec0b675db85588157d9dede7829ed51f5a90dcc9e940e5863ec4c7dfe76b82b092db203cae74342ef53c462be64d8b1c SHA512 c4376ac4dbd9b6b751e5f3265150810d51ba66a80ee4a15d1d2d8c02d24798dfd9b7c3e4344f1ea90f2ca16e98521c8c0006e6cf0e6cb3230fa17071713c9bc3
+DIST poke-3.2-el.tar.xz 15424 BLAKE2B 97e44f3515041d7bc632de261fe5ec349e0b53f2504e693243017ca2aa37ae0d7ef149829b3e2621cae838f10afb64e33688eb30636a653601ca9f9158099e81 SHA512 b94d39bd03e55ebaaefce020c1fd652dae4ee3e6079765f89e19235842f894654a483885ba80487a89bf73b12ea2955035c095669c01e4ea55a20d3eff5c1add
diff --git a/app-emacs/poke/files/50poke-el-gentoo.el b/app-emacs/poke/files/50poke-el-gentoo.el
new file mode 100644
index 000000000000..55cd5c14a628
--- /dev/null
+++ b/app-emacs/poke/files/50poke-el-gentoo.el
@@ -0,0 +1,5 @@
+;;; The GNU Emacs poke frontend site-list configuration
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload 'poke "poke"
+ "Emacs meets GNU poke!" t)
diff --git a/app-emacs/poke/metadata.xml b/app-emacs/poke/metadata.xml
new file mode 100644
index 000000000000..e2185014fbab
--- /dev/null
+++ b/app-emacs/poke/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arsen@gentoo.org</email>
+ <description>Arsen Arsenović</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ poke.el is an Emacs interface for GNU poke, the extensible editor
+ for structured binary data.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-emacs/poke/poke-3.0.ebuild b/app-emacs/poke/poke-3.0.ebuild
new file mode 100644
index 000000000000..10563c3d68a3
--- /dev/null
+++ b/app-emacs/poke/poke-3.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs meets GNU poke!"
+HOMEPAGE="https://elpa.gnu.org/packages/poke.html"
+# Rehosted ELPA tarballs for compression.
+SRC_URI="https://dev.gentoo.org/~arsen/poke-${PV}.tar.gz -> ${P}-el.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="app-emacs/poke-mode"
+RDEPEND="
+ ${DEPEND}
+ >=dev-util/poke-3.0
+"
+
+ELISP_REMOVE="poke-pkg.el"
+ELISP_TEXINFO="poke-el.texi"
+# -el here used to disambiguate with the dev-util/poke package, which
+# ships two more editing modes (for .map files and .pks files)
+SITEFILE="50${PN}-el-gentoo.el"
diff --git a/app-emacs/poke/poke-3.2.ebuild b/app-emacs/poke/poke-3.2.ebuild
new file mode 100644
index 000000000000..2b3e82699b0f
--- /dev/null
+++ b/app-emacs/poke/poke-3.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=25
+inherit elisp
+
+DESCRIPTION="Emacs meets GNU poke!"
+HOMEPAGE="https://elpa.gnu.org/packages/poke.html"
+# Rehosted ELPA tarballs for compression.
+SRC_URI="https://dev.gentoo.org/~arsen/poke-${PV}.tar.xz -> ${P}-el.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="app-emacs/poke-mode"
+RDEPEND="
+ ${DEPEND}
+ >=dev-util/poke-3.0
+"
+
+ELISP_REMOVE="poke-pkg.el"
+ELISP_TEXINFO="poke-el.texi"
+# -el here used to disambiguate with the dev-util/poke package, which
+# ships two more editing modes (for .map files and .pks files)
+SITEFILE="50${PN}-el-gentoo.el"