summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/polymode')
-rw-r--r--app-emacs/polymode/Manifest1
-rw-r--r--app-emacs/polymode/metadata.xml18
-rw-r--r--app-emacs/polymode/polymode-0.2.2_p20220322.ebuild32
3 files changed, 51 insertions, 0 deletions
diff --git a/app-emacs/polymode/Manifest b/app-emacs/polymode/Manifest
new file mode 100644
index 000000000000..913ddcd3f944
--- /dev/null
+++ b/app-emacs/polymode/Manifest
@@ -0,0 +1 @@
+DIST polymode-0.2.2_p20220322.tar.gz 417218 BLAKE2B 7f2846a6fed751f7fb0e7d6b50ca2bb40232007e7f8cef801b22b252ca39a65658d0059ddb8ba384ed2f6b1bdbddaf39fcaa09d91787b8523f9872162156f25a SHA512 2e1d49cd3086cb7a8551a4c48cd6655e1c41155f1e518b1cfae5493ac382d566bc7a8969a167063c0384978b70d79f2d2557fc9a6d12e54a985fdbf24315bf0b
diff --git a/app-emacs/polymode/metadata.xml b/app-emacs/polymode/metadata.xml
new file mode 100644
index 000000000000..f362d712f750
--- /dev/null
+++ b/app-emacs/polymode/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/polymode/polymode/issues/</bugs-to>
+ <remote-id type="github">polymode/polymode</remote-id>
+ </upstream>
+ <longdescription>
+ Polymode is a framework for multiple major modes (MMM) inside a single
+ Emacs buffer. It is fast and has a simple but flexible object oriented
+ design. Creating new polymodes normally takes a few lines of code.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-emacs/polymode/polymode-0.2.2_p20220322.ebuild b/app-emacs/polymode/polymode-0.2.2_p20220322.ebuild
new file mode 100644
index 000000000000..4b29818b0b7d
--- /dev/null
+++ b/app-emacs/polymode/polymode-0.2.2_p20220322.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+COMMIT=2094c92403fe395dfb2b8b2521da1012a966e9ab
+
+inherit elisp
+
+DESCRIPTION="Framework for Multiple Major Modes in Emacs"
+HOMEPAGE="https://github.com/polymode/polymode/"
+SRC_URI="https://github.com/polymode/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${COMMIT}
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+DOCS=( readme.md )
+# The "compat-tests" downloads resources from network and "define-tests" fails
+ELISP_REMOVE="tests/compat-tests.el tests/define-tests.el"
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . --load targets/test.el
+}
+
+src_install() {
+ elisp_src_install
+
+ dodoc -r samples
+}