summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/racket-mode')
-rw-r--r--app-emacs/racket-mode/Manifest6
-rw-r--r--app-emacs/racket-mode/racket-mode-1_p20240130.ebuild74
-rw-r--r--app-emacs/racket-mode/racket-mode-1_p20240515.ebuild74
-rw-r--r--app-emacs/racket-mode/racket-mode-20220411-r1.ebuild57
-rw-r--r--app-emacs/racket-mode/racket-mode-20220505-r1.ebuild57
-rw-r--r--app-emacs/racket-mode/racket-mode-20220628-r1.ebuild57
-rw-r--r--app-emacs/racket-mode/racket-mode-20220804.ebuild57
-rw-r--r--app-emacs/racket-mode/racket-mode-9999.ebuild74
8 files changed, 224 insertions, 232 deletions
diff --git a/app-emacs/racket-mode/Manifest b/app-emacs/racket-mode/Manifest
index ec8c867ea157..199ee5bf577e 100644
--- a/app-emacs/racket-mode/Manifest
+++ b/app-emacs/racket-mode/Manifest
@@ -1,4 +1,2 @@
-DIST racket-mode-20220411.tar.gz 303095 BLAKE2B 7fed011b915e86f6d40d6a9f8640ea2b066c201cf28e20a941fae841e96bf3649f3cf0ad7847091984a7cf490e9b98142617e47038dea70c44999510144dda3a SHA512 ec17ade728390f8f8b783703ca319ee15502afa7f82e86d9aa8b60361ecc65af21990cf89532b38bfc211887c00b5aa4c820dc0e66a1b1a1a9aacbc08673d35d
-DIST racket-mode-20220505.tar.gz 305491 BLAKE2B ca6a6ee6ae9f95f397959d9f0fa979e524ab0c6345bc5d7d67b5e681e6059175336303f06a7480d5b7ac51ae13cb851c182175eac44f37b3a21b56409f14079b SHA512 a66b991e0416f60d3a6001d17e24be95caccb627cf0e4d0f3115b7b94eda9d15583d8b94c72326708a0d5f90ab1b51711785c01d566758a4fb329bd26ea7e44c
-DIST racket-mode-20220628.tar.gz 307029 BLAKE2B 7bde6bdc971059433a1f78119e2436a24c7159f3e43b9d7c721c4a2e813de6b0a407ccc70f827c79d49d5444ba608692095b9e89175ef16070e5c4e294e53ab2 SHA512 e691dd9867ef4bc46b7380be44b8461c12a12c20191067f1ba809f218182569fcc55dc11a3db0a7438180c8f26cb24d6328ad565133e83a35e0144c547d3a5ce
-DIST racket-mode-20220804.tar.gz 308183 BLAKE2B 23ef01773f7bf0a8e44c74217d29d4e6093ce963a8d71a6f6d5227f5a23ab62023dbfa4a3ada97f4d886abdb0b48454344509bdd7cc17a2210bd23a7ca72051a SHA512 9ed5ecb0a38a5421f7103471167339e2a92e78e912ec3416975c91fb0e2526f79cfd38cdf63b60371d7ef5c4ad7087320ef6270eab15eefed80a87aad6a3f626
+DIST racket-mode-1_p20240130.tar.gz 373342 BLAKE2B 20ad54d6c64cb52d3c81004131e957c1d4ae8eb32128cb99ba043337832c7398c27d070035440efc2b2debf0324495cc1b15d45169c15da2c5efcb43ad98a71d SHA512 3bf87a0de204db58e1781899d2e1fc70d10f5493e1ae35338b8c92fa0b8ce0c5a953d05c4de60628a057d43aaa22d0d13e6f33cc8ac8073dce8e0fc3c3954bcb
+DIST racket-mode-1_p20240515.tar.gz 373968 BLAKE2B 9a704da188c0cb6948fd36135a6e8f7f7f4e8583acf10a1ed890a96d674fb300f179e8873fefcb6df4aed0f81c9210630ec995c8ad0a17f674101fc0ac9f7cd2 SHA512 b8a0126e085f1508086c437823f5cfdf076e3c857e467d4f20b63baabcfd00bd03f4caf9e9ec3773b19f530ab50e96fe40cf1ca0c77f37033321aa0e7af59b92
diff --git a/app-emacs/racket-mode/racket-mode-1_p20240130.ebuild b/app-emacs/racket-mode/racket-mode-1_p20240130.ebuild
new file mode 100644
index 000000000000..f2ad2ef65308
--- /dev/null
+++ b/app-emacs/racket-mode/racket-mode-1_p20240130.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+[[ "${PV}" == *p20240130 ]] && COMMIT=d3ab936af10909874443cadb2e6c952faf2f536f
+
+inherit elisp # virtualx
+
+DESCRIPTION="Emacs modes for Racket: edit, REPL, check-syntax, debug, profile, and more"
+HOMEPAGE="https://www.racket-mode.com/
+ https://github.com/greghendershott/racket-mode/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/greghendershott/${PN}.git"
+else
+ SRC_URI="https://github.com/greghendershott/${PN}/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
+
+ KEYWORDS="amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-scheme/racket:=[-minimal]
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+ELISP_REMOVE="
+ test/racket/hash-lang-test.rkt
+"
+PATCHES=( "${FILESDIR}/${PN}-rkt-source-dir.patch" )
+
+DOCS=( CONTRIBUTING.org README.org THANKS.org )
+ELISP_TEXINFO="doc/${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ elisp_src_prepare
+
+ sed "s|@SITEETC@|${SITEETC}/${PN}|" -i "${S}/racket-util.el" || die
+}
+
+src_compile() {
+ elisp_src_compile
+
+ # Equivalent to compiling from Emacs with "racket-mode-start-faster",
+ # because this is installed globally we have to compile it now.
+ ebegin "Compiling Racket source files"
+ find "${S}/racket" -type f -name "*.rkt" -exec raco make -v {} +
+ eend $? "failed to compile Racket source files" || die
+}
+
+src_test() {
+ # Set "PLTUSERHOME" to a safe temp directory to prevent writing to "~".
+ PLTUSERHOME="${T}/racket-mode/test-racket" emake test-racket
+}
+
+src_install() {
+ elisp_src_install
+
+ # Install Racket files to "${SITEETC}".
+ insinto "${SITEETC}/${PN}"
+ doins -r racket
+}
diff --git a/app-emacs/racket-mode/racket-mode-1_p20240515.ebuild b/app-emacs/racket-mode/racket-mode-1_p20240515.ebuild
new file mode 100644
index 000000000000..8c8b1a21c4cd
--- /dev/null
+++ b/app-emacs/racket-mode/racket-mode-1_p20240515.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+[[ "${PV}" == *p20240515 ]] && COMMIT="d2cff2b7f210846108875c7eccb1b5ab98bceb74"
+
+inherit elisp
+
+DESCRIPTION="Emacs modes for Racket: edit, REPL, check-syntax, debug, profile, and more"
+HOMEPAGE="https://www.racket-mode.com/
+ https://github.com/greghendershott/racket-mode/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/greghendershott/${PN}.git"
+else
+ SRC_URI="https://github.com/greghendershott/${PN}/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-scheme/racket:=[-minimal]
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+ELISP_REMOVE="
+ test/racket/hash-lang-test.rkt
+"
+PATCHES=( "${FILESDIR}/${PN}-rkt-source-dir.patch" )
+
+DOCS=( CONTRIBUTING.org README.org THANKS.org )
+ELISP_TEXINFO="doc/${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ elisp_src_prepare
+
+ sed "s|@SITEETC@|${SITEETC}/${PN}|" -i "${S}/racket-util.el" || die
+}
+
+src_compile() {
+ elisp_src_compile
+
+ # Equivalent to compiling from Emacs with "racket-mode-start-faster",
+ # because this is installed globally we have to compile it now.
+ ebegin "Compiling Racket source files"
+ find "${S}/racket" -type f -name "*.rkt" -exec raco make -v {} +
+ eend $? "failed to compile Racket source files" || die
+}
+
+src_test() {
+ # Set "PLTUSERHOME" to a safe temp directory to prevent writing to "~".
+ PLTUSERHOME="${T}/racket-mode/test-racket" emake test-racket
+}
+
+src_install() {
+ elisp_src_install
+
+ # Install Racket files to "${SITEETC}".
+ insinto "${SITEETC}/${PN}"
+ doins -r racket
+}
diff --git a/app-emacs/racket-mode/racket-mode-20220411-r1.ebuild b/app-emacs/racket-mode/racket-mode-20220411-r1.ebuild
deleted file mode 100644
index 0777c1053a90..000000000000
--- a/app-emacs/racket-mode/racket-mode-20220411-r1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-H=e7efbb52fdf2219532230a199153d8a33889c26f
-NEED_EMACS=25.1
-
-inherit elisp
-
-DESCRIPTION="Emacs modes for Racket: edit, REPL, check-syntax, debug, profile, and more"
-HOMEPAGE="https://github.com/greghendershott/racket-mode/"
-SRC_URI="https://github.com/greghendershott/${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}"/${PN}-${H}
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-
-RDEPEND="dev-scheme/racket:=[-minimal]"
-BDEPEND="${RDEPEND}"
-
-PATCHES=( "${FILESDIR}"/${PN}-rkt-source-dir.patch )
-
-DOCS=( CONTRIBUTING.md README.md THANKS.md )
-
-ELISP_TEXINFO="doc/racket-mode.texi"
-SITEFILE="50${PN}-gentoo.el"
-
-src_prepare() {
- elisp_src_prepare
-
- sed "s|@SITEETC@|${SITEETC}/${PN}|" -i racket-util.el || die
-}
-
-src_compile() {
- elisp_src_compile
-
- # Equivalent to compiling from Emacs with "racket-mode-start-faster",
- # because this is installed globally we have to compile it now.
- ebegin "Compiling Racket source files"
- find "${S}"/racket -type f -name "*.rkt" -exec raco make -v {} +
- eend $? "failed to compile Racket source files" || die
-}
-
-src_test() {
- # Set "PLTUSERHOME" to a safe temp directory to prevent writing to ~.
- PLTUSERHOME="${T}"/racket-mode/test-racket emake test-racket
-}
-
-src_install() {
- elisp_src_install
-
- # Install Racket files
- insinto "${SITEETC}/${PN}"
- doins -r racket
-}
diff --git a/app-emacs/racket-mode/racket-mode-20220505-r1.ebuild b/app-emacs/racket-mode/racket-mode-20220505-r1.ebuild
deleted file mode 100644
index f88a71dda156..000000000000
--- a/app-emacs/racket-mode/racket-mode-20220505-r1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-H=fbb4a4664e2cc2b5d21eee62735f73b7f0272e60
-NEED_EMACS=25.1
-
-inherit elisp
-
-DESCRIPTION="Emacs modes for Racket: edit, REPL, check-syntax, debug, profile, and more"
-HOMEPAGE="https://github.com/greghendershott/racket-mode/"
-SRC_URI="https://github.com/greghendershott/${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}"/${PN}-${H}
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-
-RDEPEND="dev-scheme/racket:=[-minimal]"
-BDEPEND="${RDEPEND}"
-
-PATCHES=( "${FILESDIR}"/${PN}-rkt-source-dir.patch )
-
-DOCS=( CONTRIBUTING.md README.md THANKS.md )
-
-ELISP_TEXINFO="doc/racket-mode.texi"
-SITEFILE="50${PN}-gentoo.el"
-
-src_prepare() {
- elisp_src_prepare
-
- sed "s|@SITEETC@|${SITEETC}/${PN}|" -i racket-util.el || die
-}
-
-src_compile() {
- elisp_src_compile
-
- # Equivalent to compiling from Emacs with "racket-mode-start-faster",
- # because this is installed globally we have to compile it now.
- ebegin "Compiling Racket source files"
- find "${S}"/racket -type f -name "*.rkt" -exec raco make -v {} +
- eend $? "failed to compile Racket source files" || die
-}
-
-src_test() {
- # Set "PLTUSERHOME" to a safe temp directory to prevent writing to ~.
- PLTUSERHOME="${T}"/racket-mode/test-racket emake test-racket
-}
-
-src_install() {
- elisp_src_install
-
- # Install Racket files
- insinto "${SITEETC}/${PN}"
- doins -r racket
-}
diff --git a/app-emacs/racket-mode/racket-mode-20220628-r1.ebuild b/app-emacs/racket-mode/racket-mode-20220628-r1.ebuild
deleted file mode 100644
index 2d3780799ccf..000000000000
--- a/app-emacs/racket-mode/racket-mode-20220628-r1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-H=77c2d41c9ab041c383dfc60ed6ae562c4e953130
-NEED_EMACS=25.1
-
-inherit elisp
-
-DESCRIPTION="Emacs modes for Racket: edit, REPL, check-syntax, debug, profile, and more"
-HOMEPAGE="https://github.com/greghendershott/racket-mode/"
-SRC_URI="https://github.com/greghendershott/${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}"/${PN}-${H}
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="dev-scheme/racket:=[-minimal]"
-BDEPEND="${RDEPEND}"
-
-PATCHES=( "${FILESDIR}"/${PN}-rkt-source-dir.patch )
-
-DOCS=( CONTRIBUTING.md README.md THANKS.md )
-
-ELISP_TEXINFO="doc/racket-mode.texi"
-SITEFILE="50${PN}-gentoo.el"
-
-src_prepare() {
- elisp_src_prepare
-
- sed "s|@SITEETC@|${SITEETC}/${PN}|" -i racket-util.el || die
-}
-
-src_compile() {
- elisp_src_compile
-
- # Equivalent to compiling from Emacs with "racket-mode-start-faster",
- # because this is installed globally we have to compile it now.
- ebegin "Compiling Racket source files"
- find "${S}"/racket -type f -name "*.rkt" -exec raco make -v {} +
- eend $? "failed to compile Racket source files" || die
-}
-
-src_test() {
- # Set "PLTUSERHOME" to a safe temp directory to prevent writing to ~.
- PLTUSERHOME="${T}"/racket-mode/test-racket emake test-racket
-}
-
-src_install() {
- elisp_src_install
-
- # Install Racket files
- insinto "${SITEETC}/${PN}"
- doins -r racket
-}
diff --git a/app-emacs/racket-mode/racket-mode-20220804.ebuild b/app-emacs/racket-mode/racket-mode-20220804.ebuild
deleted file mode 100644
index 51d1f7db319f..000000000000
--- a/app-emacs/racket-mode/racket-mode-20220804.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-H=89238bde54b3e9b6c85c6ce8437aa44a73fb71e1
-NEED_EMACS=25.1
-
-inherit elisp
-
-DESCRIPTION="Emacs modes for Racket: edit, REPL, check-syntax, debug, profile, and more"
-HOMEPAGE="https://github.com/greghendershott/racket-mode/"
-SRC_URI="https://github.com/greghendershott/${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}"/${PN}-${H}
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="dev-scheme/racket:=[-minimal]"
-BDEPEND="${RDEPEND}"
-
-PATCHES=( "${FILESDIR}"/${PN}-rkt-source-dir.patch )
-
-DOCS=( CONTRIBUTING.md README.md THANKS.md )
-
-ELISP_TEXINFO="doc/racket-mode.texi"
-SITEFILE="50${PN}-gentoo.el"
-
-src_prepare() {
- elisp_src_prepare
-
- sed "s|@SITEETC@|${SITEETC}/${PN}|" -i racket-util.el || die
-}
-
-src_compile() {
- elisp_src_compile
-
- # Equivalent to compiling from Emacs with "racket-mode-start-faster",
- # because this is installed globally we have to compile it now.
- ebegin "Compiling Racket source files"
- find "${S}"/racket -type f -name "*.rkt" -exec raco make -v {} +
- eend $? "failed to compile Racket source files" || die
-}
-
-src_test() {
- # Set "PLTUSERHOME" to a safe temp directory to prevent writing to ~.
- PLTUSERHOME="${T}"/racket-mode/test-racket emake test-racket
-}
-
-src_install() {
- elisp_src_install
-
- # Install Racket files
- insinto "${SITEETC}/${PN}"
- doins -r racket
-}
diff --git a/app-emacs/racket-mode/racket-mode-9999.ebuild b/app-emacs/racket-mode/racket-mode-9999.ebuild
new file mode 100644
index 000000000000..eec06b7a6ff2
--- /dev/null
+++ b/app-emacs/racket-mode/racket-mode-9999.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# COMMIT=""
+
+inherit elisp
+
+DESCRIPTION="Emacs modes for Racket: edit, REPL, check-syntax, debug, profile, and more"
+HOMEPAGE="https://www.racket-mode.com/
+ https://github.com/greghendershott/racket-mode/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/greghendershott/${PN}.git"
+else
+ SRC_URI="https://github.com/greghendershott/${PN}/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-scheme/racket:=[-minimal]
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+ELISP_REMOVE="
+ test/racket/hash-lang-test.rkt
+"
+PATCHES=( "${FILESDIR}/${PN}-rkt-source-dir.patch" )
+
+DOCS=( CONTRIBUTING.org README.org THANKS.org )
+ELISP_TEXINFO="doc/${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ elisp_src_prepare
+
+ sed "s|@SITEETC@|${SITEETC}/${PN}|" -i "${S}/racket-util.el" || die
+}
+
+src_compile() {
+ elisp_src_compile
+
+ # Equivalent to compiling from Emacs with "racket-mode-start-faster",
+ # because this is installed globally we have to compile it now.
+ ebegin "Compiling Racket source files"
+ find "${S}/racket" -type f -name "*.rkt" -exec raco make -v {} +
+ eend $? "failed to compile Racket source files" || die
+}
+
+src_test() {
+ # Set "PLTUSERHOME" to a safe temp directory to prevent writing to "~".
+ PLTUSERHOME="${T}/racket-mode/test-racket" emake test-racket
+}
+
+src_install() {
+ elisp_src_install
+
+ # Install Racket files to "${SITEETC}".
+ insinto "${SITEETC}/${PN}"
+ doins -r racket
+}