summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/reazon')
-rw-r--r--app-emacs/reazon/Manifest1
-rw-r--r--app-emacs/reazon/metadata.xml22
-rw-r--r--app-emacs/reazon/reazon-0.4.1.ebuild20
3 files changed, 43 insertions, 0 deletions
diff --git a/app-emacs/reazon/Manifest b/app-emacs/reazon/Manifest
new file mode 100644
index 000000000000..9bfd387c63c3
--- /dev/null
+++ b/app-emacs/reazon/Manifest
@@ -0,0 +1 @@
+DIST reazon-0.4.1.tar.gz 38654 BLAKE2B 1e2cc22c58b030bb504c47d5526b01a2f8d64f0e1fc95456313199defc847c0066aee3931d57c27592919a57633905951d3ab67cfa4a61035946609c772cf685 SHA512 fda8cda62bdf0818990a3a9bb5893b75bd4e875ecb6e6a280a1992e1d9b4b621e8ee7eac8e1d3ec0e06bf9bc8a37414695702247e5782e2859e4d8126906bf5f
diff --git a/app-emacs/reazon/metadata.xml b/app-emacs/reazon/metadata.xml
new file mode 100644
index 000000000000..8b0170cd063f
--- /dev/null
+++ b/app-emacs/reazon/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ Reazon is an Emacs implementation of miniKanren, a small domain-specific
+ logic programming language. Whereas languages like Elisp deal with
+ functions that take inputs and yield outputs, miniKanren deals with sets of
+ values that satisfy relations. Every function is a relation, but not vice
+ versa, since a relation might include the output of a function but not its
+ inputs. In such a case, miniKanren would attempt to find inputs yielding
+ the output, effectively running the function backwards.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/nickdrozd/reazon/issues/</bugs-to>
+ <remote-id type="github">nickdrozd/reazon</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/reazon/reazon-0.4.1.ebuild b/app-emacs/reazon/reazon-0.4.1.ebuild
new file mode 100644
index 000000000000..e86dc1835a0b
--- /dev/null
+++ b/app-emacs/reazon/reazon-0.4.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26
+
+inherit elisp
+
+DESCRIPTION="GNU Emacs implementation of miniKanren, logic programming language"
+HOMEPAGE="https://github.com/nickdrozd/reazon/"
+SRC_URI="https://github.com/nickdrozd/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( CHANGELOG.org README.org )
+SITEFILE="50${PN}-gentoo.el"