summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/rg')
-rw-r--r--app-emacs/rg/Manifest1
-rw-r--r--app-emacs/rg/rg-2.3.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-emacs/rg/Manifest b/app-emacs/rg/Manifest
index 0d335e64e66b..ffd4b27d91eb 100644
--- a/app-emacs/rg/Manifest
+++ b/app-emacs/rg/Manifest
@@ -1 +1,2 @@
DIST rg-2.2.1.tar.gz 202686 BLAKE2B 43abfdc5d631d5551272788dc31f8767f2b638604f180dfd0cb96df8d142f97ec644482da660c279f1877ab77477e5f25810de3850439d0210be1e4040c77a98 SHA512 eac9c21db6a13299e24f3e6166ff45f378f44454bc02ad8c04b42580d03c67eb28fbaee17feaa53096b7dced2e4e7dbf64a50608c61fe9188530fa0102a0f240
+DIST rg-2.3.0.tar.gz 204996 BLAKE2B cc233f90a4bd56928053ebace2aa166c0210ddc9720b37b4e67e10e1082ed0ff744bef6d502666a8094d9c57c0afa2b9a32967b290443cc467f2865ea7b95330 SHA512 343626c35bdb26f2a300bac258af112230cf502900852456362f1adaa6bf6551d42d07ced59b8f864cab0663b559262f2e6f982f5b95cfffe1d04218fe6ebbbe
diff --git a/app-emacs/rg/rg-2.3.0.ebuild b/app-emacs/rg/rg-2.3.0.ebuild
new file mode 100644
index 000000000000..e3cadd443056
--- /dev/null
+++ b/app-emacs/rg/rg-2.3.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="GNU Emacs search tool based on ripgrep"
+HOMEPAGE="https://rgel.readthedocs.io/
+ https://github.com/dajva/rg.el/"
+SRC_URI="https://github.com/dajva/rg.el/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/rg.el-${PV}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ app-emacs/transient
+ app-emacs/wgrep
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ sys-apps/ripgrep
+"
+BDEPEND="
+ ${COMMON_DEPEND}
+ test? (
+ app-emacs/ert-runner
+ app-emacs/s
+ app-emacs/undercover
+ )
+"
+
+DOCS=( README.md )
+ELISP_REMOVE="test/rg.el-test.el test/rg-isearch.el-test.el"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}
+
+src_test() {
+ ert-runner -L . -L test --reporter ert+duration --script test || die
+}
+
+src_install() {
+ elisp_src_install
+ doinfo rgel.info
+}