summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/scala-ts-mode')
-rw-r--r--app-emacs/scala-ts-mode/Manifest1
-rw-r--r--app-emacs/scala-ts-mode/files/50scala-ts-mode-gentoo.el2
-rw-r--r--app-emacs/scala-ts-mode/metadata.xml11
-rw-r--r--app-emacs/scala-ts-mode/scala-ts-mode-1.0.0_p20240316.ebuild33
4 files changed, 47 insertions, 0 deletions
diff --git a/app-emacs/scala-ts-mode/Manifest b/app-emacs/scala-ts-mode/Manifest
new file mode 100644
index 000000000000..135433dd008d
--- /dev/null
+++ b/app-emacs/scala-ts-mode/Manifest
@@ -0,0 +1 @@
+DIST scala-ts-mode-1.0.0_p20240316.tar.gz 18330 BLAKE2B aedcfa91563421673435def9dc2679d5c9f1feb1dde6214e8e7650ca8d72e6165253140bc506ba67cbc00b4e54d9edbb34db47089438b6de2e42699bf15ebfa7 SHA512 544622840cfefbab79ddae06d48cc5a9a6fb1802fd18f7c2b425b921713392e6d84b287dcdb3fa65d08d59f5af28ec2b23711685764affaf854238d3583b0cd3
diff --git a/app-emacs/scala-ts-mode/files/50scala-ts-mode-gentoo.el b/app-emacs/scala-ts-mode/files/50scala-ts-mode-gentoo.el
new file mode 100644
index 000000000000..47898c79b2cb
--- /dev/null
+++ b/app-emacs/scala-ts-mode/files/50scala-ts-mode-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "@SITELISP@/scala-ts-mode-autoloads" nil t)
diff --git a/app-emacs/scala-ts-mode/metadata.xml b/app-emacs/scala-ts-mode/metadata.xml
new file mode 100644
index 000000000000..7e270e83dac9
--- /dev/null
+++ b/app-emacs/scala-ts-mode/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Florian Schmaus</name>
+ <email>flow@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">KaranAhlawat/scala-ts-mode</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/scala-ts-mode/scala-ts-mode-1.0.0_p20240316.ebuild b/app-emacs/scala-ts-mode/scala-ts-mode-1.0.0_p20240316.ebuild
new file mode 100644
index 000000000000..f7cfef4ef361
--- /dev/null
+++ b/app-emacs/scala-ts-mode/scala-ts-mode-1.0.0_p20240316.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+MY_COMMIT="11a01d726ac4fafb8a6688459ac79b41333bd6c8"
+DESCRIPTION="Emacs Scala Mode via Tree-Sitter"
+HOMEPAGE="https://github.com/KaranAhlawat/scala-ts-mode"
+SRC_URI="
+ https://codeload.github.com/KaranAhlawat/scala-ts-mode/tar.gz/${MY_COMMIT}
+ -> ${P}.tar.gz
+"
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64"
+
+RDEPEND="
+ >=app-editors/emacs-29[tree-sitter]
+ dev-libs/tree-sitter-scala
+"
+
+DOCS="README.org"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}