summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/setup')
-rw-r--r--app-emacs/setup/Manifest1
-rw-r--r--app-emacs/setup/files/50setup-gentoo.el2
-rw-r--r--app-emacs/setup/metadata.xml9
-rw-r--r--app-emacs/setup/setup-1.2.0.ebuild26
4 files changed, 38 insertions, 0 deletions
diff --git a/app-emacs/setup/Manifest b/app-emacs/setup/Manifest
new file mode 100644
index 000000000000..d34c9d677d34
--- /dev/null
+++ b/app-emacs/setup/Manifest
@@ -0,0 +1 @@
+DIST setup-1.2.0.tar.gz 19709 BLAKE2B 704340f9ab8a3e10fdeafed88365fb3151fe8c9600960defcce0021850a1846ffc5e7a3c02a4567371c18b4bdf5b81c80544fe82c22a150ca4d4505818ba8148 SHA512 705e188876316eb76938229395676a9068e735074d63865dd9a2a21d83face2768f958f76cf9c88b6cb3d4668e271ee043d7aa81a40d3b384fb1bc75bb1f0af5
diff --git a/app-emacs/setup/files/50setup-gentoo.el b/app-emacs/setup/files/50setup-gentoo.el
new file mode 100644
index 000000000000..be25af07cd53
--- /dev/null
+++ b/app-emacs/setup/files/50setup-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "@SITELISP@/setup-autoloads" nil t)
diff --git a/app-emacs/setup/metadata.xml b/app-emacs/setup/metadata.xml
new file mode 100644
index 000000000000..986088003fe1
--- /dev/null
+++ b/app-emacs/setup/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<stabilize-allarches/>
+</pkgmetadata>
diff --git a/app-emacs/setup/setup-1.2.0.ebuild b/app-emacs/setup/setup-1.2.0.ebuild
new file mode 100644
index 000000000000..2fc7d0dfd7dc
--- /dev/null
+++ b/app-emacs/setup/setup-1.2.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+NEED_EMACS=26
+
+# The upstream does not create git tags for releases.
+MY_HASH=4fc13e309ec1585a7e5033c394fa25a3078e39c5
+
+inherit elisp
+
+DESCRIPTION="Macro to simplify repetitive configuration patterns"
+HOMEPAGE="https://git.sr.ht/~pkal/setup"
+SRC_URI="https://git.sr.ht/~pkal/${PN}/archive/${MY_HASH}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${MY_HASH}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}