summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/swiper')
-rw-r--r--app-emacs/swiper/Manifest1
-rw-r--r--app-emacs/swiper/swiper-0.14.2.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/app-emacs/swiper/Manifest b/app-emacs/swiper/Manifest
index 45fe46a14f11..41097db74b88 100644
--- a/app-emacs/swiper/Manifest
+++ b/app-emacs/swiper/Manifest
@@ -1 +1,2 @@
DIST swiper-0.14.0.tar.gz 249820 BLAKE2B 9184e66f910b9f7c401c9a5433b5915c393ece7711858c3f844d8afcbc13fa76039173b2ecd50bbaff586ff7596fd95e46e550a4282763e385f064d2e2103978 SHA512 e87fa2159d1541afdaa08e33584480cbeba75df15235bf57d4c8f6292b91be7e2a316e931c3f4d823da5fbf23d987ded293a433824af04357de231d26adfeeb1
+DIST swiper-0.14.2.tar.gz 250059 BLAKE2B 8a5437726c729398a689266d138f271f5f7329f9c58613c4e0cfabd16b99421035c4b522d0ea4c60c0369362cb076bcae05ff4155d33d186172fd0ac2258495d SHA512 e125a3747abc4e6ecc98f539cf5dde11851d6c8a58b8988e165300bce7822fc91257cae09c973bd43435fb08dc24af9a1bd4b3e51083b45654b1605d80973d74
diff --git a/app-emacs/swiper/swiper-0.14.2.ebuild b/app-emacs/swiper/swiper-0.14.2.ebuild
new file mode 100644
index 000000000000..569f7e380a5b
--- /dev/null
+++ b/app-emacs/swiper/swiper-0.14.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Alternative to isearch that uses ivy to show overview of all matches"
+HOMEPAGE="https://github.com/abo-abo/swiper/"
+SRC_URI="https://github.com/abo-abo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # Ivy, Swiper and Counsel tests are performed in app-emacs/ivy
+
+RDEPEND=">=app-emacs/ivy-${PV}"
+BDEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile ${PN}.el
+}
+
+src_install() {
+ elisp-install ${PN} ${PN}.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}