summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/tempel/tempel-1.0.ebuild')
-rw-r--r--app-emacs/tempel/tempel-1.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-emacs/tempel/tempel-1.0.ebuild b/app-emacs/tempel/tempel-1.0.ebuild
new file mode 100644
index 000000000000..8a32fe684d94
--- /dev/null
+++ b/app-emacs/tempel/tempel-1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Templates with in-buffer field editing for GNU Emacs"
+HOMEPAGE="https://github.com/minad/tempel/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+else
+ SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND=">=app-emacs/compat-29.1.3.4"
+BDEPEND="${RDEPEND}"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}