summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/treemacs/treemacs-2.10-r2.ebuild')
-rw-r--r--app-emacs/treemacs/treemacs-2.10-r2.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/app-emacs/treemacs/treemacs-2.10-r2.ebuild b/app-emacs/treemacs/treemacs-2.10-r2.ebuild
index 21707f71d5e4..de552c5b30b2 100644
--- a/app-emacs/treemacs/treemacs-2.10-r2.ebuild
+++ b/app-emacs/treemacs/treemacs-2.10-r2.ebuild
@@ -5,7 +5,7 @@ EAPI=8
NEED_EMACS=26.1
DISTUTILS_USE_PEP517=no
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit elisp distutils-r1
@@ -34,14 +34,14 @@ BDEPEND="
test? ( app-emacs/buttercup )
"
-DOCS=( Changelog.org Extensions.org README.org screenshots )
+BYTECOMPFLAGS="-L . -L src/elisp"
PATCHES=(
"${FILESDIR}"/${PN}-2.9.5-tests.patch
"${FILESDIR}"/${PN}-async-scripts.patch
"${FILESDIR}"/${PN}-icons-icon-directory.patch
)
-BYTECOMPFLAGS="-L . -L src/elisp"
+DOCS=( Changelog.org Extensions.org README.org screenshots )
SITEFILE="50${PN}-gentoo.el"
src_prepare() {
@@ -58,6 +58,7 @@ python_compile() {
src_compile() {
distutils-r1_src_compile
+
elisp-compile src/elisp/*.el
}