summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/treemacs')
-rw-r--r--app-emacs/treemacs/Manifest5
-rw-r--r--app-emacs/treemacs/files/treemacs-3.0-tests.patch31
-rw-r--r--app-emacs/treemacs/treemacs-2.9.5-r2.ebuild75
-rw-r--r--app-emacs/treemacs/treemacs-3.0-r1.ebuild76
-rw-r--r--app-emacs/treemacs/treemacs-3.1-r1.ebuild (renamed from app-emacs/treemacs/treemacs-2.10-r2.ebuild)53
-rw-r--r--app-emacs/treemacs/treemacs-3.1_p20240229.ebuild83
6 files changed, 114 insertions, 209 deletions
diff --git a/app-emacs/treemacs/Manifest b/app-emacs/treemacs/Manifest
index 1ff141dac693..67c445fbf04e 100644
--- a/app-emacs/treemacs/Manifest
+++ b/app-emacs/treemacs/Manifest
@@ -1,3 +1,2 @@
-DIST treemacs-2.10.tar.gz 4137468 BLAKE2B 0f832d02f8b0f96f7000c57b1842319155face5cb50c44ff4286f7f28dd74b38739079de9c387dbddbf93af37a5c750c45a598100ed5053674a565b4ec34f0c6 SHA512 9326a3f66c1b38eb7ef39e90900c2ef71d20c6c3478213f61c144ca4face562dccf00d6d400315c264627468a0c3319a24f0ec6cddb795b54e1b7f3c235d1c71
-DIST treemacs-2.9.5.tar.gz 4134227 BLAKE2B 1fbdb278e9524fdb14cbc7699bc787ab694b00d37a91ec3e91e106079bc02f6b8b39207608873d45c70fd6355a22553bf1a0636a948b79df77adfe0b4a3f799f SHA512 adc026d7ad459418fae531c5a1a7df7f9308e63dec82240c1c5e278eb00fdf8d6dff1ee2112ea73d5a05c4266efe24623bb84f8819a6f07fbb4fde6e644ca9ad
-DIST treemacs-3.0.tar.gz 4552082 BLAKE2B d12dff7aa667916ba586dcf47d642b36987ec1612a5dd276a513eef551c7b81a463d55531dacc48eac49ffc7390b1dd48a7e07285d188d4d40e779b9bc0b09f5 SHA512 981eb40973c86aec683ad6f0436c853e9254bfa10e77a60d3c36ef8b18d76dce358d68dee06355e63b4040c816e4f0064a3e722a414db0f9d3d007e5d252d753
+DIST treemacs-3.1.tar.gz 4562915 BLAKE2B b728c6ea795fe1159c2342b593cc4e6b3d06a1ba58dca876e5472e394b77a3a9930740aa9ecb65973f551322018920f08b0b49e897d5677b7a0f1da42cfad2d3 SHA512 e891cfa68916ecc250ab0446a4eb0149deea17a7f366870ce757e73f175bc823dae87080a584ea315d502c50559d030055f2f399cbd92d40af8c2dca5308604c
+DIST treemacs-3.1_p20240229.tar.gz 4701534 BLAKE2B 3b3e5dbef181efee4739f96ee0ef0de68f344fa68b890b22c0ec808ec1c3b7afc6cd353124e2c6e5e70c931492ac0c9a3e4cee5c66b5c25ba4cc72b296ade6f0 SHA512 40631b77a71b13b0aed2f703386d98b8444c7630f952ba8d49160ba99abc13b8636169fee8cd23bbc372a7d7ae83b863e11ac891deb8cc5d2e961ccfee9f60da
diff --git a/app-emacs/treemacs/files/treemacs-3.0-tests.patch b/app-emacs/treemacs/files/treemacs-3.0-tests.patch
deleted file mode 100644
index d7bc67dc3e54..000000000000
--- a/app-emacs/treemacs/files/treemacs-3.0-tests.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-Disable bad tests.
-
---- a/test/treemacs-test.el
-+++ b/test/treemacs-test.el
-@@ -372,7 +372,7 @@
-
- (describe "treemacs--parent"
-
-- (it "Fails on nil input"
-+ (xit "Fails on nil input"
- (expect (treemacs--parent nil) :to-throw))
-
- (it "Returns nil when input is empty"
-@@ -393,14 +393,14 @@
- (it "Returns directory extension of extension sub-item node."
- (expect (treemacs--parent '("/test1" "a" "b")) :to-equal '("/test1" "a")))
-
-- (it "Returns directory of a directory extension node."
-+ (xit "Returns directory of a directory extension node."
- (expect (treemacs--parent '("/test1" "a")) :to-equal "/test1"))
-
-- (it "Returns project extension of a project sub-item node."
-+ (xit "Returns project extension of a project sub-item node."
- (let ((p (treemacs-project->create! :path "/A" :path-status 'local-readable)))
- (expect (treemacs--parent (list p "a" "b")) :to-equal (list p "a"))))
-
-- (it "Returns project of a project extension node."
-+ (xit "Returns project of a project extension node."
- (let ((p (treemacs-project->create! :path "/A" :path-status 'local-readable)))
- (expect (treemacs--parent (list p "a")) :to-equal "/A"))))
-
diff --git a/app-emacs/treemacs/treemacs-2.9.5-r2.ebuild b/app-emacs/treemacs/treemacs-2.9.5-r2.ebuild
deleted file mode 100644
index 847fece21ce8..000000000000
--- a/app-emacs/treemacs/treemacs-2.9.5-r2.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-NEED_EMACS=26.1
-DISTUTILS_USE_PEP517=no
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit elisp distutils-r1
-
-DESCRIPTION="Tree style project file explorer"
-HOMEPAGE="https://github.com/Alexander-Miller/treemacs/"
-SRC_URI="https://github.com/Alexander-Miller/${PN}/archive/${PV}.tar.gz
- -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-KEYWORDS="~amd64"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- app-emacs/ace-window
- app-emacs/cfrs
- app-emacs/dash
- app-emacs/ht
- app-emacs/hydra
- app-emacs/pfuture
- app-emacs/s
-"
-BDEPEND="
- ${RDEPEND}
- test? ( app-emacs/buttercup )
-"
-
-DOCS=( Changelog.org Extensions.org README.org screenshots )
-PATCHES=(
- "${FILESDIR}"/${PN}-async-scripts.patch
- "${FILESDIR}"/${PN}-icons-icon-directory.patch
- "${FILESDIR}"/${P}-tests.patch
-)
-
-BYTECOMPFLAGS="-L . -L src/elisp"
-SITEFILE="50${PN}-gentoo.el"
-
-src_prepare() {
- distutils-r1_src_prepare
-
- sed "s|@SITEETC@|${SITEETC}/${PN}|g" \
- -i src/elisp/${PN}-icons.el \
- -i src/elisp/${PN}-async.el || die
-}
-
-python_compile() {
- python_optimize "${S}"/src/scripts
-}
-
-src_compile() {
- distutils-r1_src_compile
- elisp-compile src/elisp/*.el
-}
-
-src_test() {
- buttercup ${BYTECOMPFLAGS} -L test --traceback full || die "tests failed"
-}
-
-src_install() {
- elisp-install ${PN} src/elisp/*.el{,c}
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
-
- insinto ${SITEETC}/${PN}
- doins -r icons
- doins -r src/scripts
-}
diff --git a/app-emacs/treemacs/treemacs-3.0-r1.ebuild b/app-emacs/treemacs/treemacs-3.0-r1.ebuild
deleted file mode 100644
index 5b225323539c..000000000000
--- a/app-emacs/treemacs/treemacs-3.0-r1.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-NEED_EMACS=26.1
-DISTUTILS_USE_PEP517=no
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit elisp distutils-r1
-
-DESCRIPTION="Tree style project file explorer"
-HOMEPAGE="https://github.com/Alexander-Miller/treemacs/"
-SRC_URI="https://github.com/Alexander-Miller/${PN}/archive/${PV}.tar.gz
- -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-KEYWORDS="~amd64"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- app-emacs/ace-window
- app-emacs/cfrs
- app-emacs/dash
- app-emacs/ht
- app-emacs/hydra
- app-emacs/pfuture
- app-emacs/s
-"
-BDEPEND="
- ${RDEPEND}
- test? ( app-emacs/buttercup )
-"
-
-DOCS=( Changelog.org Extensions.org README.org screenshots )
-PATCHES=(
- "${FILESDIR}"/${PN}-2.9.5-tests.patch
- "${FILESDIR}"/${PN}-async-scripts.patch
- "${FILESDIR}"/${PN}-icons-icon-directory.patch
- "${FILESDIR}"/${P}-tests.patch
-)
-
-BYTECOMPFLAGS="-L . -L src/elisp"
-SITEFILE="50${PN}-gentoo.el"
-
-src_prepare() {
- distutils-r1_src_prepare
-
- sed "s|@SITEETC@|${SITEETC}/${PN}|g" \
- -i src/elisp/${PN}-icons.el \
- -i src/elisp/${PN}-async.el || die
-}
-
-python_compile() {
- python_optimize "${S}"/src/scripts
-}
-
-src_compile() {
- distutils-r1_src_compile
- elisp-compile src/elisp/*.el
-}
-
-src_test() {
- buttercup ${BYTECOMPFLAGS} -L test --traceback full || die "tests failed"
-}
-
-src_install() {
- elisp-install ${PN} src/elisp/*.el{,c}
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
-
- insinto ${SITEETC}/${PN}
- doins -r icons
- doins -r src/scripts
-}
diff --git a/app-emacs/treemacs/treemacs-2.10-r2.ebuild b/app-emacs/treemacs/treemacs-3.1-r1.ebuild
index 21707f71d5e4..5f04a6ad831c 100644
--- a/app-emacs/treemacs/treemacs-2.10-r2.ebuild
+++ b/app-emacs/treemacs/treemacs-3.1-r1.ebuild
@@ -1,26 +1,33 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
NEED_EMACS=26.1
DISTUTILS_USE_PEP517=no
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{10..12} )
-inherit elisp distutils-r1
+inherit distutils-r1 elisp
DESCRIPTION="Tree style project file explorer"
HOMEPAGE="https://github.com/Alexander-Miller/treemacs/"
-SRC_URI="https://github.com/Alexander-Miller/${PN}/archive/${PV}.tar.gz
- -> ${P}.tar.gz"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/Alexander-Miller/${PN}.git"
+else
+ SRC_URI="https://github.com/Alexander-Miller/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64"
+fi
LICENSE="GPL-3+"
-KEYWORDS="~amd64"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="
+ >=app-editors/emacs-${NEED_EMACS}[svg]
app-emacs/ace-window
app-emacs/cfrs
app-emacs/dash
@@ -31,45 +38,43 @@ RDEPEND="
"
BDEPEND="
${RDEPEND}
- test? ( app-emacs/buttercup )
"
-DOCS=( Changelog.org Extensions.org README.org screenshots )
+BYTECOMPFLAGS="-L . -L src/elisp"
PATCHES=(
- "${FILESDIR}"/${PN}-2.9.5-tests.patch
- "${FILESDIR}"/${PN}-async-scripts.patch
- "${FILESDIR}"/${PN}-icons-icon-directory.patch
+ "${FILESDIR}/${PN}-2.9.5-tests.patch"
+ "${FILESDIR}/${PN}-async-scripts.patch"
+ "${FILESDIR}/${PN}-icons-icon-directory.patch"
)
-BYTECOMPFLAGS="-L . -L src/elisp"
+DOCS=( Changelog.org Extensions.org README.org screenshots )
SITEFILE="50${PN}-gentoo.el"
+elisp-enable-tests buttercup test
+
src_prepare() {
distutils-r1_src_prepare
- sed "s|@SITEETC@|${SITEETC}/${PN}|g" \
- -i src/elisp/${PN}-icons.el \
- -i src/elisp/${PN}-async.el || die
+ sed "s|@SITEETC@|${SITEETC}/${PN}|g" \
+ -i "src/elisp/${PN}-icons.el" \
+ -i "src/elisp/${PN}-async.el" || die
}
python_compile() {
- python_optimize "${S}"/src/scripts
+ python_optimize "${S}/src/scripts"
}
src_compile() {
distutils-r1_src_compile
- elisp-compile src/elisp/*.el
-}
-src_test() {
- buttercup ${BYTECOMPFLAGS} -L test --traceback full || die "tests failed"
+ elisp-compile src/elisp/*.el
}
src_install() {
- elisp-install ${PN} src/elisp/*.el{,c}
+ elisp-install "${PN}" src/elisp/*.el{,c}
elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- insinto ${SITEETC}/${PN}
+ insinto "${SITEETC}/${PN}"
doins -r icons
doins -r src/scripts
}
diff --git a/app-emacs/treemacs/treemacs-3.1_p20240229.ebuild b/app-emacs/treemacs/treemacs-3.1_p20240229.ebuild
new file mode 100644
index 000000000000..b7337b3db652
--- /dev/null
+++ b/app-emacs/treemacs/treemacs-3.1_p20240229.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+DISTUTILS_USE_PEP517=no
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 elisp
+
+DESCRIPTION="Tree style project file explorer"
+HOMEPAGE="https://github.com/Alexander-Miller/treemacs/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/Alexander-Miller/${PN}.git"
+else
+ COMMIT_SHA=8c6df39f01a4d47fda2cc943645fa067f771b748
+ SRC_URI="https://github.com/Alexander-Miller/${PN}/archive/${COMMIT_SHA}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT_SHA}"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=app-editors/emacs-${NEED_EMACS}[svg]
+ app-emacs/ace-window
+ app-emacs/cfrs
+ app-emacs/dash
+ app-emacs/ht
+ app-emacs/hydra
+ app-emacs/pfuture
+ app-emacs/s
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+BYTECOMPFLAGS="-L . -L src/elisp"
+PATCHES=(
+ "${FILESDIR}/${PN}-2.9.5-tests.patch"
+ "${FILESDIR}/${PN}-async-scripts.patch"
+ "${FILESDIR}/${PN}-icons-icon-directory.patch"
+)
+
+DOCS=( Changelog.org Extensions.org README.org screenshots )
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests buttercup test
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ sed -e "s|@SITEETC@|${SITEETC}/${PN}|g" \
+ -i "src/elisp/${PN}-icons.el" \
+ -i "src/elisp/${PN}-async.el" \
+ || die
+}
+
+python_compile() {
+ python_optimize "${S}/src/scripts"
+}
+
+src_compile() {
+ distutils-r1_src_compile
+
+ elisp-compile src/elisp/*.el
+}
+
+src_install() {
+ elisp-install "${PN}" src/elisp/*.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ insinto "${SITEETC}/${PN}"
+ doins -r icons
+ doins -r src/scripts
+}