summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/treepy')
-rw-r--r--app-emacs/treepy/Manifest1
-rw-r--r--app-emacs/treepy/files/50treepy-gentoo.el1
-rw-r--r--app-emacs/treepy/metadata.xml18
-rw-r--r--app-emacs/treepy/treepy-0.1.1.ebuild19
4 files changed, 39 insertions, 0 deletions
diff --git a/app-emacs/treepy/Manifest b/app-emacs/treepy/Manifest
new file mode 100644
index 000000000000..fd54d692927c
--- /dev/null
+++ b/app-emacs/treepy/Manifest
@@ -0,0 +1 @@
+DIST treepy-0.1.1.tar.gz 125004 BLAKE2B 2aab285f0a0ce0d14cde0d6567efd062d4e2bf944421e8c4e5c3ef62965a43c7abc77d88c5baeadbe2cbe4e98dce9d563fc5b02abae8e83194dbb058d78db725 SHA512 70790f83e7f33846ca4c568c79c45bfea9a29cc92b717053eb2fa89a22a77578d80f31f19002c61d254d4b2c4c36f345324c0d631412477f09713b51124dfb83
diff --git a/app-emacs/treepy/files/50treepy-gentoo.el b/app-emacs/treepy/files/50treepy-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/treepy/files/50treepy-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/treepy/metadata.xml b/app-emacs/treepy/metadata.xml
new file mode 100644
index 000000000000..4d60dd6e94bb
--- /dev/null
+++ b/app-emacs/treepy/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<longdescription>
+Generic tools for recursive and iterative tree traversal based on
+clojure.walk and clojure.zip respectively. Depends on `map', a map
+manipulation library built in Emacs 25.1. All functions are prefixed
+with "treepy-"
+</longdescription>
+<stabilize-allarches/>
+<upstream>
+ <remote-id type="github">volrath/treepy.el</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-emacs/treepy/treepy-0.1.1.ebuild b/app-emacs/treepy/treepy-0.1.1.ebuild
new file mode 100644
index 000000000000..9e85cb0c484d
--- /dev/null
+++ b/app-emacs/treepy/treepy-0.1.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="Generic tree traversing tools for Emacs Lisp"
+HOMEPAGE="https://github.com/volrath/treepy.el"
+SRC_URI="https://github.com/volrath/treepy.el/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}.el-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+SITEFILE="50${PN}-gentoo.el"
+DOCS="README.md"