summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/treesit-auto')
-rw-r--r--app-emacs/treesit-auto/Manifest1
-rw-r--r--app-emacs/treesit-auto/treesit-auto-1.0.3.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-emacs/treesit-auto/Manifest b/app-emacs/treesit-auto/Manifest
index 0b8185e2daea..bd4c29001d2c 100644
--- a/app-emacs/treesit-auto/Manifest
+++ b/app-emacs/treesit-auto/Manifest
@@ -1 +1,2 @@
DIST treesit-auto-1.0.2.tar.gz 24776 BLAKE2B 5f8604140c49f3c76fae801c77bed5fdcd005bc8379926eb0e80c0dc1f2802247313d6b1de4180ab53281f4ccfb1ccbd446e1a010962ea4de5d63b7154104dde SHA512 af7a4c3b135cf275211514ea7621b10a00baa715a53f950f3b7049150a75078d02e6b2041d8d507e3a04d06af30e1db971d63c4c742bdc75661930fe50c4f30c
+DIST treesit-auto-1.0.3.tar.gz 24841 BLAKE2B 89698a4810888d27f4c012301fb4f21ed1e9f8ce5cc774f1fa80add7257dbaaa3dbf23d32680542d6b54a841b1bb8d5ca81a6d07d5827a66139a21ab54492f35 SHA512 cd8c2fa23a154abdd883b82b8e465697acf48ce6ae2e0abc1aa8b7f99fd0e7f3266e13f79299fd5ac5be51402ef62c6f643d708ce290f6205a2e47a46b94cac1
diff --git a/app-emacs/treesit-auto/treesit-auto-1.0.3.ebuild b/app-emacs/treesit-auto/treesit-auto-1.0.3.ebuild
new file mode 100644
index 000000000000..f60b9db41667
--- /dev/null
+++ b/app-emacs/treesit-auto/treesit-auto-1.0.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=29
+
+inherit elisp
+
+DESCRIPTION="Automatic installation, usage, fallback for tree-sitter modes in Emacs 29"
+HOMEPAGE="https://github.com/renzmann/treesit-auto/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/renzmann/${PN}.git"
+else
+ SRC_URI="https://github.com/renzmann/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"