summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/uboat')
-rw-r--r--app-emacs/uboat/files/uboat-1.2-iap.patch11
-rw-r--r--app-emacs/uboat/uboat-1.2-r1.ebuild (renamed from app-emacs/uboat/uboat-1.2.ebuild)7
2 files changed, 15 insertions, 3 deletions
diff --git a/app-emacs/uboat/files/uboat-1.2-iap.patch b/app-emacs/uboat/files/uboat-1.2-iap.patch
new file mode 100644
index 000000000000..585b385a42e3
--- /dev/null
+++ b/app-emacs/uboat/files/uboat-1.2-iap.patch
@@ -0,0 +1,11 @@
+--- uboat-1.2/uboat.el
++++ uboat-1.2/uboat.el
+@@ -79,7 +79,7 @@
+ (let ((s (concat (uboat-iterate-list (uboat-random-member uboat-message)
+ "uboat-")
+ " U-" (int-to-string (random 999)) ".")))
+- (and (interactive-p)
++ (and (called-interactively-p 'interactive)
+ (message "%s" s))
+ s))
+
diff --git a/app-emacs/uboat/uboat-1.2.ebuild b/app-emacs/uboat/uboat-1.2-r1.ebuild
index 54d83286e69e..5bc62c517fd6 100644
--- a/app-emacs/uboat/uboat-1.2.ebuild
+++ b/app-emacs/uboat/uboat-1.2-r1.ebuild
@@ -1,17 +1,18 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit elisp
DESCRIPTION="Generate u-boat-death messages, patterned after Iron Coffins"
HOMEPAGE="http://www.splode.com/~friedman/software/emacs-lisp/"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.bz2"
# Noah Friedman and Bob Manson have confirmed that this is in the public domain
LICENSE="public-domain"
SLOT="0"
KEYWORDS="amd64 ppc x86"
+PATCHES=( "${FILESDIR}/${P}-iap.patch" )
SITEFILE="50${PN}-gentoo.el"